Clang_32 wants to compile x86_64



  • I just downloaded Qt 5.0.2 source and compiled/installed it on Mac OS X 10.8.3 using:

    /configure -prefix /QtSDK/Qt5.0.2/5.0.2/clang_32 -platform macx-clang-32

    and then I opened a project that I've been compiling using Qt 4.8.4 which I compiled and installed using the old -arch i384 configure option. When I now try to compile the project, I get the following error:

    ignoring file /QtSDK/Qt5.0.2/5.0.2/clang_32/lib/QtGui.framework/QtGui, file was built for unsupported file format ( 0xce 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 0 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (x86_64): /QtSDK/Qt5.0.2/5.0.2/clang_32/lib/QtGui.framework/QtGui

    As I read this, it says that its trying to target x86_64 for an installation compiled for i386.

    How do I fix this?

    Sincerely,
    Dan



  • Just to add a little bit more information, I used qmake to create an XCode project, and from XCode, the application compiles perfectly with a handful of warnings but no errors. And it seems to run just fine. So I'm thinking the issue is with a Qt Creator setting and not a qmake issue. Anyone know what I could be doing wrong?


  • Lifetime Qt Champion

    Hi,

    Check the compiler used in your Kits for your Qt version



  • Yes, that's the first thing I tried after having compiled and installed the clang32 libraries. So I went to manage kits, then I manually added a new kit, "Desktop Qt 5.0.2 clang 32bit," and used the compiler pull down menu to select Clang (x86 32 bit).


  • Lifetime Qt Champion

    Strange...
    Can you try to add

    @CONFIG+=x86@

    to your pro file ?



  • Yes, I tried that early on as well.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.