[SOLVED] Trying to get a 5-way navigation to work on Sitara AM335x Starter Kit



  • I bought a Sitara AM335x Starter Kit and I am trying to create a QT application that can be navigated with a 5-way button. The problem is the buttons on the form only can be moved between by using the up and down arrow. I tried rebuilding QT with this command...

    sudo ./configure -embedded arm -xplatform /home/nrogers/ti-sdk-am335x-evm-05.05.00.00/linux-devkit/mkspecs/qws/linux-arm-gnueabi-g++/ -release -opensource -little-endian -host-little-endian -confirm-license -no-qt3support -no-neon -no-separate-debug-info -nomake examples -nomake tools -nomake docs -nomake demos -qt-kbd-linuxinput -no-armfpa -DQT_KEYPAD_NAVIGATION -no-webkit

    As you can see I included the -DQT_KEYPAD_NAVIGATION flag so I thought it would make the QApplication::setNavigationMode() function available to me. However when I try to complie in QT Creator the function still isn't found. I thought all I would have to do is change my qmake under teh Qt Version tab under Build & Run to the qmake under my Trolltech folder but it doesn't work.

    Is what I am trying to do even possiable? I just want to be able to put buttons and other things on the screen and have the arrow buttons navigate through them in a natural way without having to tell the application what to do each time an arrow button is pressed. Any help or ideas is greatly appriciated, thanks!



  • I ended up using QtQuick and the KeyNavigation feature to implement my 5-Way button and it works really well.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.