Launch Qt Server Application at startup ?



  • Hi,

    I am currently working on a "Freescale iMX6 SABRE Lite Board":http://boundarydevices.com/products/sabre-lite-imx6-sbc/, which is a running on Arch Linux with LXDE ("this":http://archlinuxarm.org/platforms/armv7/nitrogen6x is the image I use). I have cross-compiled a Qt application on my development machine for this board, and this application seems to work fine on my board.

    Now, I would like to be able to launch it automatically at startup. For this, I have a bash script which moves into the directory of the application, and launches it with the qws option (without this option, the application doesn't launch and just prints this error : QWSSocket::connectToLocalFile could not connect:: No such file or directory). In a terminal, when LXDE is already launched, it works like a charm.
    But when using it from my /etc/xdg/lxsession/LXDE/autostart file, it doesn't really work : when I launch the startx command from my console, LXDE starts, and the pixels behind my mouse cursor go green (just like when the application launches), but after this nothing.

    My question is : is there a specific way to do what I want, which is launching this application (with the qws option) automatically ?
    Of course, since I am really new to embedded programmation and cross compilation, I don't exclude at all the possibility of a problem with the compilation of my program. To do this, I followed "this":http://treyweaver.blogspot.com.es/2010/10/setting-up-qt-development-environment.html guide. If there is a more specific, or better and/or simpler way to cross compile my Qt applications, I would be glad hearing about it :)

    Any help would be greatly appreciated :)



  • I think this post not related to Qt it's LXDE issue so I suggest to ask LXDE guys.

    Any way, I faced same issue with KDE as mentioned in this post... read it it may help you :)
    https://forum.kde.org/viewtopic.php?f=18&t=110847


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.