[Solved]how install qt on ubuntu?

  • I downloaded qt-linux-opensource-5.0.2-x86-offline.run and i cant install it on ubuntu.
    please tell me how i can install it.

  • Lifetime Qt Champion


    To be helped, you have to give more informations like version of Ubuntu, error output etc...

  • Moderators

    Make the file executable if it is not already.

  • this is all i have done.
    moslem@moslem-945GZ-CT-M:~$ cd /media/moslem/0EB40068B400549D/
    moslem@moslem-945GZ-CT-M:/media/moslem/0EB40068B400549D$ chmod +x qt-linux-opensource-5.0.2-x86-offline.run
    moslem@moslem-945GZ-CT-M:/media/moslem/0EB40068B400549D$ sudo ./qt-linux-opensource-5.0.2-x86-offline.run
    [sudo] password for moslem:
    sudo: ./qt-linux-opensource-5.0.2-x86-offline.run: command not found

  • Moderators

    Hm, I've experienced that a few times in the old Nokia SDK. I don't know what is the cause - for me it worked sometimes, but I couldn't pinpoint the root of the problem.

    EDIT hey, you don't need to run this as root! User privileges are enough.

  • My ubuntu is 12.10.
    when i write

    without sudo it shows me

    @Permission denied@

  • Moderators

    sudo chown <your username> qt-linux-opensource-5.0.2-x86-offline.run
    sudo chmod 777 qt-linux-opensource-5.0.2-x86-offline.run

    1. start terminal
    2. navigate to the folder with your .run file (eg. cd /home/downloads/)
    3. type: sudo chmod +x qt-linux-opensource-5.0.2-x86-offline.run (Enter)
    4. type: ./qt-linux-opensource-5.0.2-x86-offline.run (Enter - the installation wizard should start)

  • I wrote your code and show me this

    @moslem@moslem-945GZ-CT-M:/media/moslem/0EB40068B400549D$ sudo chown moslem qt-linux-opensource-5.0.2-x86-offline.run
    moslem@moslem-945GZ-CT-M:/media/moslem/0EB40068B400549D$ sudo chmod 777 qt-linux-opensource-5.0.2-x86-offline.run
    what must I do now?

  • Moderators

    Run the binary, just like before:

  • Oh, thanks everyone I've found out why it showed me the error. I must use 'sudo' before 'chmod'

  • Moderators

    "command not found" is (among other things) linux prosaic way about mismatched binary word sizes.

    So are you sure you are on a 32bit ubuntu? Or on a 64bit ubuntu with a 32bit set of libraries installed in addition to the normal 64bit ones?

Log in to reply