What QT Version path to use when setting a Build & Run Kit for the Angstrom Qt embedded distribution



    1. I installed the angstrom toolchain to work with the BeagleBone
    2. I tested that the toolchain works by compiling a miniature QT Application (it just creates a text file to proove that it ran). Copied the program onto the BeagleBone sshed into the BeagleBone and ran the QT application that created the file as expected. So far so good.
    3. I installed QT Creator 2.6.2, created a project with a desktop application, compiled and ran it on the desktop no issue there.
    4. Since I want to cross-compile I went to project view and started creating a new Build & Run Kit but I have no idea what value to create for the Qt Version field when creating that Build Kit?

  • Moderators

    The same settings as used to build your example project. Same qmake, tool chain, etc.

    What exactly is your problem?



  • Found what I needed in the script I ran to setup and test the toolchain before installing Qt:

    export SDK_PATH=/usr/local/angstrom/arm
    export TARGET_SYS=arm-angstrom-linux-gnueabi
    export PATH=$SDK_PATH/bin:$PATH
    export CPATH=$SDK_PATH/$TARGET_SYS/usr/include:$CPATH
    export LIBTOOL_SYSROOT_PATH=$SDK_PATH/$TARGET_SYS
    export PKG_CONFIG_SYSROOT_DIR=$SDK_PATH/$TARGET_SYS
    export PKG_CONFIG_PATH=$SDK_PATH/$TARGET_SYS/usr/lib/pkgconfig
    export CONFIG_SITE=$SDK_PATH/site-config
    alias opkg="LD_LIBRARY_PATH=$SDK_PATH/lib $SDK_PATH/bin/opkg-cl -f $SDK_PATH//etc/opkg-sdk.conf -o $SDK_PATH"
    alias opkg-target="LD_LIBRARY_PATH=$SDK_PATH/lib $SDK_PATH/bin/opkg-cl -f $SDK_PATH/$TARGET_SYS/etc/opkg.conf -o $SDK_PATH/$TARGET_SYS"
    export OE_QMAKE_CC=arm-angstrom-linux-gnueabi-gcc
    export OE_QMAKE_CXX=arm-angstrom-linux-gnueabi-g++
    export OE_QMAKE_LINK=arm-angstrom-linux-gnueabi-g++
    export OE_QMAKE_AR=arm-angstrom-linux-gnueabi-ar
    export OE_QMAKE_LIBDIR_QT=/usr/local/angstrom/arm/arm-angstrom-linux-gnueabi//usr/lib
    export OE_QMAKE_INCDIR_QT=/usr/local/angstrom/arm/arm-angstrom-linux-gnueabi//usr/include/qtopia
    export OE_QMAKE_MOC=/usr/local/angstrom/arm/bin/moc4
    export OE_QMAKE_UIC=/usr/local/angstrom/arm/bin/uic4
    export OE_QMAKE_UIC3=/usr/local/angstrom/arm/bin/uic34
    export OE_QMAKE_RCC=/usr/local/angstrom/arm/bin/rcc4
    export OE_QMAKE_QDBUSCPP2XML=/usr/local/angstrom/arm/bin/qdbuscpp2xml4
    export OE_QMAKE_QDBUSXML2CPP=/usr/local/angstrom/arm/bin/qdbusxml2cpp4
    export OE_QMAKE_QT_CONFIG=/usr/local/angstrom/arm/arm-angstrom-linux-gnueabi//usr/share/qtopia/mkspecs/qconfig.pri
    export QMAKESPEC=/usr/local/angstrom/arm/arm-angstrom-linux-gnueabi//usr/share/qtopia/mkspecs/linux-g++



  • Back to square one, I could not get things to work.

    Here is a picture of the error displayed in the Manage Kits option screen:

    !http://photos2.meetupstatic.com/photos/event/6/a/3/8/highres_214047192.jpeg(Photo of error displayed in the manage kits screen)!





  • I got things to cross-compile but I still get that Black Background Error in the Manage Kits screen. It is not blocking but it is annoying not to know why QT Creator is complaining, I am obviously doing something in a sub-optimal way for QT Creator to complain like that... plus I fear some side effects down the road.


  • Moderators

    The only issue I see is with the Qt version: Creator can not figure out which architecture the Qt version is targeting.

    Creator will try to read the QtCore library from where qmake -query points to (library directory). Either it does not find a libQtCore.so* there or it does not know the binary format of that file.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.