[SOLVED] No Maintenance Tool - no python script. how to uninstall Qt from a Mac?



  • Hey there,

    I tried to install Qt 4.8.3 (Creator 2.6.2) with on my Mac (10.8.2 Mountain Lion). Running projects which ran on other Macs failed to built. So, after a while I pretty fucked up everything on my system.

    I have no maintenance tool anymore, and don't know why. I don't have the python script neither. Please, I am desperate; How can I uninstall Qt for a clean re-install?

    I really like to work with Qt.
    Thanks in advance!

    Rob


  • Lifetime Qt Champion

    Hello,

    How did you install Qt ?



  • Hey SGaist!

    On this page, I clicked the DOWNLOADS tab, downloaded the Mac Version of 4.8
    Qt libraries 4.8.4 for Mac (185 MB) and debug libraries (480 MB) and installed it.

    As I said (didn't know about the ###), I really messed it up, while not being able running projects. So I tried 5 then 4.8, and I was able to uninstall both again with the python script as well as the maintenance tool. But now, nothing is available anymore...

    EDIT:
    Even the examples aren't there anymore.



  • Hello. Did you tried to have a look (via xterm) in the subfolders of /usr/ ? or use the locate command (or find) to try to find one file present in qt (e.g a source file present in qt) ?

    Maybe you will find the path of your qt install by this way ?



  • There is some in /System/Library/Frameworks/QTKit.framework. But does this help me? I guess just remove these files isn't really a clean uninstall, isn't it?


  • Lifetime Qt Champion

    Don't touch one ! It's for QuickTime (QT) not Qt (Yes casing is really important here)



  • Have a look in your /usr/local/ folder, maybe you will find the qt install folder (by default my qt install is there (mac os x 10.7 & qt5). If you find it there, remove the folder by using the command rm -rf yourQtFolder

    and as SGaist said, be carefull with casing. And look only in /usr/local (if you used the binaries for your install as you said before, the setup floder should be there).



  • Haha, thanks for mention that! But any suggestions yet for the actual problem?

    I just saw, that there is also content in /Applications/Qt Creator.app/Contents/...
    Any chance, that this is helpful?



  • No, it's juste Qt creator app. you can use a soft like AppCleaner to remove it. For Qt itself, try what i suggested on my last post



  • I just looked. In the /usr is nothing like Qt and no folder 'local'.

    Since Creator is running but working, isn't it possible, that all files are removed allready but the ones in /Application/...



  • Murphy is gone!

    Thread can be closed. I just removed the files in /Application/... cause they seemed to be the last one. Reinstalled Qt 5 and it runs. Thanks to all of you.



  • Great :D Don't forget to edit the title and add the [SOLVED] tag ;)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.