Qt Embedded Linux with framebuffer



  • Hi everybody

    I wish to build QT5 with framebuffer support and webkit too.
    When I ran configure with -platform linux-g++ (in Xubuntu 12.04.1) I had the following message:
    ...Qt was built without ICU support.. " and also framebuffer was disabled.

    What does it mean and how can I have framebuffer support on my platform?
    Thanks



  • The switch "-qt-gfx-linuxfb" must be used when configuring qt in order to enable the linux framebuffer driver.
    As for "ICU" it's the localization backend for Qt5



  • There isn't any "-gfx" option and I've already configured (and built) with "-qt-linuxfb" but when I run an application without X there's a crash dump.



  • I've run other applications in framebuffer mode just for scientific purposes as I plan to run Qt-only applications in framebuffer mode. I will experiment with this in a few days (perhaps this weekend), then I'll return here to see if I can help...



  • in Qt5x, we need to give -qpa linuxFB when we do configure on QT source code.

    Example:

    @./configure -opensource -confirm-license -xplatform qws/linux-windriver-g++ -prefix INSTALL_PATH -arch powerpc -qpa LinuxFB -openssl -no-sql-mysql -no-sql-db2 -nomake tools -nomake examples -skip qtwebkit -skip qtwebkit-examples -v@

    See the -qpa flag in the above code.

    Let me know incase you further encounter any doubts/errors.

    Cheers!!



  • It's quite an old post... but anyway...

    If you want to compile qtwebkit too (@Sid reply suggest you to remove qtwebkit from compilation process, but it is not what you want) then you need to also compile ICU since qtwebkit relies on ICU for internationalization...

    So, grab the last version of ICU4C (from "here":http://site.icu-project.org/) and compile it (see instructions on ICU web site for doing that)... Once you have compiled ICU then you have to reference it in your Qt's configure options... Personally I usually add something like:

    -icu -I /path/to/ICU/includes -L /path/to/ICU/libs -R /path/to/ICU/libs

    to my Qt's ./configure options, and usually it works... :)



  • Dear Morix Dev, yes you are correct, my point was only to point out the -qpa flag. I posted the same configure code that i used in my project without webkit.

    :)



  • Thanks everybody


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.