Solved: installing 4.8.4 libraries on MacOS



  • I really should know how to do this by now, but...I just ran the (binary) installer. Seemed to work fine, but...where did the files go? All the installer told me was what drive. Creator can't find them. Help?

    Thanks.

    EDIT:

    Cliff Notes for those encountering similar problems: this is probably more accurately considered a problem with accessing, rather than installing, the Qt libraries. The problem evidently exists because the Mac OS architecture forces the Qt installation to be scattered all over the directory structure, including into directories that are invisible to Qt (and the typical user). Creating a soft link to the /usr directory seems to have solved this.


  • Moderators

    They are basically scattered all over the OS.

    Some files are in /Library/Frameworks, some in /Developer, some in /usr/bin. This is one of the reasons why I prefer prefixed builds from source. Takes more time, but gives greater control.



  • Sigh. OK, well, let me ask this, then...now that I've used the binary installation, can I still find the MinGW library through Creator?

    Or, am I better off to bite the bullet and go the source route?


  • Moderators

    I think qmake is in /usr/bin, but cannot check now. You can search for qmake in Finder, and then feed that path to Qt Creator in Tools>Options>Build & Run>Qt Versions.

    And it's not minGW, Mac uses g++ and/ or clang.



  • I just did a search from terminal, on the entire drive, and found only the qmake file for 4.8.1. And...not a single file name containing "4.8.4" on the entire disk...they must have changed naming conventions for this version.

    I don't suppose that 5.0 has simplified the installation process? I'm tempted to just tear out all of this and start over.


  • Moderators

    Apple is not making it all easier either :) Recent releases of Xcode and changes in file structure have messed up a lot. I do not know about Qt5 on Mac, I have tested it on Linux and Windows only. You can give Qt5 RC a try. It includes a full SDK, so maybe it would be more straightforward.

    What output do you get when you run:
    @
    which qmake
    @

    from terminal? Also, run
    @
    qmake -v
    @

    Maybe that would help.



  • Oho...this is interesting:

    @unknownd49a20f3c0dc:64_GB_SSD mzimmers$ which qmake
    /usr/bin/qmake
    unknownd49a20f3c0dc:64_GB_SSD mzimmers$ qmake -v
    QMake version 2.01a
    Using Qt version 4.8.4 in /Library/Frameworks
    unknownd49a20f3c0dc:64_GB_SSD mzimmers$
    @

    Yet a search in /Library/Frameworks reveals no qmake file.


  • Moderators

    So the /usr/bin/qmake is the binary for 4.8.4, but the libraries (dylibs/ frameworks) reside in /Library/Frameworks. That's the standard Mac mess ;) If Qt Creator still does not see qmake, add the one from /usr/bin and see what happens.



  • Well, that presents a problem of its own: Creator won't let me into the /usr directory (probably because it's invisible). I created an alias, but the Qt Versions ->Add... dialog evidently won't accept an alias.


  • Moderators

    :( Symlink will work perhaps?

    This is bad. I'm sure there was another qmake somewhere else, but as said - can't check now, I've only got a Mac machine at work (luckily ;) ). Or we are back at compiling from source.



  • Using the link did seem to work. I modified my default kit to run with the 4.8.4 libraries and didn't get any complaints.

    Thanks for the help. I do look forward for the day when the Mac OS architecture doesn't require the Qt installer to be so cumbersome.


  • Moderators

    Good to hear that. Per aspera ad astra, as they say :)



  • Same problem, but I don't realize how do you solve.
    Could you explain for me?
    Thank you.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    If you need to get qmake from /usr/bin:

    • Do as before (click on choose)
    • Go to Macintosh HD
    • Presss CMD + SHIFT + .

    That will temporarily show hidden folders. Then you can access /usr

    Hope it helps



  • SGaist,
    Thank you very much!!!
    You are my hero.



  • Hi I have the same problem here:

    I followed the suggestion there and indeed find that there is /usr/bin/qmake and it is indeed "Using Qt version 4.8.5 in /Library/Frameworks"

    Following the SGaist's advice I use the command+shift+. to reveal hidden files.

    Now I can see both qmake under /usr/bin BUT it is greyed out and I just CANNOT select it.

    Can someone help?



  • Hi I have the same problem here:

    I followed the suggestion there and indeed find that there is /usr/bin/qmake and it is indeed "Using Qt version 4.8.x in /Library/Frameworks"

    Following the SGaist's advice I use the command+shift+. to reveal hidden files.

    Now I can see both qmake under /usr/bin BUT it is greyed out and I just CANNOT select it.

    Can someone help?


  • Lifetime Qt Champion

    What version of Qt Creator are you using ?



  • Not the same person, but I have the same issue with usr/bin/qmake being greyed out. I'm using Qt Creator 3.0.1.


  • Lifetime Qt Champion

    Are you sure that /usr/bin/qmake is not a symbolic link that points to nowhere ?



  • Just got it working actually, it was an ownership issue. Changing it with "sudo chown" in terminal got it fixed:

    cd usr/bin
    sudo chown [username] qmake

    Thanks!

    Edit: Wow nope, spoke too soon. Once I changed the ownership, the Qt version automatically showed up under "Manual" so I thought everything was good. I changed tabs to add the version to my kit but it wouldn't show up in the drop-down menu. I closed the Preferences window (I didn't hit "apply") and reopened it, now the Qt version is gone and it's still greyed out when I try to select it.



  • I managed to finally load qmake but in a rather roundabout way.

    I followed an earlier suggest and made an alias for qmake on my documents folder using Symlink.

    ln -s /usr/bin/qmake Documents/qmake

    But I also saw this alias qmake as greyed out.

    I then reinstalled the Qt5 binary package that includes Qt Creator and Qt 5 library (I earlier uninstalled this in preparation for installing the 4.8.5 library and Creator separately).

    I choose Preference>Qt Version and choose Add.

    I could now see the alias qmake which I selected.

    I uninstalled the QtCreator+Qt 5 combo.

    I started the Qt Creator installed earlier on a separate dir. I could now see the alias qmake as not greyed out. But the actual qmake as revealed by command+shift+. was still greyed out.

    Now I have successfully installed Qt 4.8.5

    This is a rather round about way and I am sure I must have turned on something by accident which could have been got at by a much shorter. But nonetheless this is how I got it working.

    I wish it could be a lot less painful


  • Lifetime Qt Champion

    Glad you succeeded but it's indeed pretty convoluted...



  • Thanks vwcc, I uninstalled and reinstalled everything and now it works.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.