Error: A data abort exception has occurred



  • Hi,everyone.

    I want to develop a app that can play mp3 via network with Qt in my Symbian device 5230.
    So I had choose Phonon and multimedia of QtMobility to have a test.

    But both Phonon and multimedia are not working.

    Phonon version:
    @
    Phonon::MediaObject *music = Phonon::createPlayer(Phonon::MusicCategory,Phonon::MediaSource("http://www.cenet.org.cn/userfiles/2009-2-9/20090209213949675.mp3"));
    music->play();
    @
    QtMobility version:
    @
    QMediaPlayer *player=new QMediaPlayer(this);
    player->setMedia(QUrl("http://www.cenet.org.cn/userfiles/2009-2-9/20090209213949675.mp3"));
    player->setVolume(50);
    player->play();
    @
    I could generate the sis file. And it did't work on the 5230. I add the 5230 to debug with:
    and the problem is :
    @
    Installing application...
    Starting application...
    Application running with pid 2222.
    Process 2222, thread 2223 stopped at 0x797255b6: A data abort exception has occurred.
    Finished.
    @

    P.S:I test both phonon and mediaplayer to play the local mp3 file.They worked well.
    and I also test the Phonon as a Desktop version to play local mp3 file and mp3 via network. It played well.

    Anyone met the problem? Or anyone would have suggestions to play mp3 via a URL with Qt for Symbian?
    Thx!



  • Please ignore the person above me.

    Symbian requires an extra line for network to work on device.
    You may need to modify the PRO file with:
    @
    symbian {
    TARGET.CAPABILITY += NetworkServices
    }
    @
    If you created the project in QtCreator 2.1, it will have this option available when you create it 'Enable Network Access'

    In which case you just need:
    @

    Needs to be defined for Symbian

    DEFINES += NETWORKACCESS
    @



  • Thanks for your reply.

    as you said,I add "CAPABILITY += NetworkServices WriteDeviceData ReadDeviceData" to the pro file.
    then I also add Qt += network to make the qt app to access the internet.

    what did you mean of "DEFINES += NETWORKACCESS" Should it add to the pro file ?



  • Yes,My sdk is Qt for Symbian4.7.1

    why did you said the network was damaged?



  • Oh in QtCreator 2.1, it adds a PRI (rules) file that allows you to use that DEFINES line to get network working properly. No need to mess with anything else.

    If you're not using 2.1, just do what you've done.

    Is it working now?



  • I see you're adding those videos. They don't really prove much in this case though.

    For what it's worth, all Qt networking apps work perfect on Symbian 4.7.1 here.
    It is likely a configuration error. Config may have changed between 4.7.0 and 4.7.1, I'm not sure. I use create new project on new Qt bases to avoid such issues.



  • sorry to reply for you so late.
    I'm a newbie for Qt for Symbian.

    You meaned that I would add a .pri file to my project?
    and the content of .pri file is
    @ Needs to be defined for Symbian
    DEFINES += NETWORKACCESS
    @#?

    How does the app work with the .pri file? should it include by the .cpp file or the .h file?



  • I also met the second "Bug" you post when I was developing an app using network of Qt.

    I met the [Qt Message] exception on 3 [will close the socket handle - hack] when I debug the app.

    I don't know why the new version turn up so many bug? The new version SDK should work more stable than the last version,isn't is?

    I will try the method you suppose.I will link to you if there are other questions.

    Thanks very much.



  • It's interesting because obviously it doesn't happen to everyone (whoever released Qt4.7.1 for Symbian and me, for starters).

    I wonder what you (tamhanna) and hisong1988 have in common here.
    I really don't think my phone's firmware has changed this.

    About the PRI files: they are included in your PRO file. If you make new project in QtCreator2.1, this will be set out for you. Otherwise, don't worry about it.
    Maybe you should try QtCreator 2.1.



  • Hello,tamhanna

    Yes,the capability "ReaUserData WriteUserData NetworkServices" I add to the pro file. It didn't work.

    Mostly,I really want to know how does this problem "A data abort exception has occurred
    " happened?



  • I will try the newest Creator.

    My device is nokia5230, I also think the qt4.7 or QtMobility doesn't work well on the device?

    It will work well in the newest nokia Phone and the future's.

    what do you think?



  • Moving this over because tam won't:

    [quote author="tamhanna" date="1291541138"]Hi,
    no - QFtp also failed, as can be seen in the two videos.[/quote]

    Oh, well this is entirely different. I thought you were compiling QFtp from source, like I assume hisong is for his program.
    How about when running Qt4.7.0 networking apps on your phone. Your phone has Qt4.7.1 installed, right?



  • Yes, It needs more tests to the Qt for symbian and the developing would more smoothly.

    I will test the Qt4.6.2 for Symbian toninght.

    nice talking to you. I have supper first.



  • [quote author="tamhanna" date="1291541194"]Hello hisong,
    the old versions of Qt worked well. In fact, Qt 4.6.2 worked the best ever - after that, it got worse.[/quote]

    I have the opposite. Qt4.7 is running very fast and without many bugs on my phone's.

    I'm wondering, have you installed Qt4.7.1 (qt_installer.sis) on your phone?



  • hi xsacha.

    Actually, I had already installed the Qt4.7.1 (qt_installer.sis) on my phone.
    other apps developed with Qt work well on my Phone.

    I think I need to reset the Qt developing environment for your app you developed runned well on your phone.

    All right,what device that you have to test your apps? I only have 5800 and 5230.



  • You can test your app on a wide range of phones using RDA on Forum Nokia.



  • Hi, xsacha. Are you available now? I'm hisong.

    I try the QtCreator2.1 RC to build my project. But, the problem "A data abort exception has occurred"still appeared.

    This time.I found that when I build the Mobile Qt Application(with UI)project. The app seemed to it was working(There is no issue happened).
    I could see the app connect the network. But the app couldn't play the mp3 via internet!!

    and I bulid the Qt Console Application project. The problem " data abort exception has occurred" appeared.

    Both of the tests above I created with the creator2.1.

    I just add a little code from the book "Qt for Symbian" to my project....
    Please give me a hand ? Thanks.



  • Hi,tamhanna..
    I try the creator2.1 that xsacha suggested yesterday. I found that it didn't work.So I decides to followed your suggestion. But at first I want to know that have you try to play mp3 via internet via internet used GSM(not wifi or 3G)?



  • I am experiencing the same issue: using Phonon to play a remote mp3 stream in Symbian (5800XM) results in the already mentioned "A data abort exception has occurred". I am assuming that "QTBUG-13952":http://bugreports.qt.nokia.com/browse/QTBUG-13952 solves this problem -- would someone be able to confirm this?



  • How do you use QMediaPlayer Of Qt Mobility?

    I tried it, but failed too.



  • Hi,amppa.

    Now I have the problem is that I can't play mp3 via network.

    I can play local mp3 using Phonon or QMediaPlayer of Qt Mobility.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.