Header file missing with error "e32math.h: No such directory"

  • Hi
    I am new to Qt Development and just was having problem with building a project "Sensor-Eval" available at following link

    I have actually installed and setup following in order in my machine




    qt-sdk-win-opensource-2010.05 (http://qt.nokia.com/downloads/sdk-windows-cpp)

    Nokia_Qt_SDK_Win_offline_v1_0_2_en (http://www.forum.nokia.com/info/sw.nokia.com/id/e920da1a-5b18-42df-82c3-907413e525fb/Nokia_Qt_SDK.html)

    ISSUE with the project "Sensor-Eval"
    When I try to build it. the following error occurs in spsensor.cpp
    @e32math.h: No such directory@

    I just tried to search for the file on the web and I found that it has to be in Symbian SDK. Then I tried to look for it in the Symbian_3 SDK Documentation (installed with the SDK). I actually found the information about this header file in the documentation but I couldn't locate it in the system(on disk path) where I installed the Symbian_3 SDK.

    can any one help in this regard?

    There are also several other examples in the Qt Creator which are not able to build and mostly having the issue of missing header files

  • the e32math.h file should be located in the "Nokia_Symbian3_SDK_v0.9\epoc32\include" folder ... maybe your installation has an issue. Also note that this example's readme says:
    Target Platforms / Platform Specifics:

    • Qt 4.6.2
    • Qt Mobility APIs Beta
    • S60 5th Edition Version 1.0
    • Nokia N97 Version 1.0

    I still tried to build with symbian^3 and ended with a different error:

    sensoreval/src/sensors/spsensor.cpp:520: error: 'const class QtMobility::QGeoPositionInfo' has no member named 'dateTime'

    to dig further :(

  • some bug in forum, the error should be

    error: 'const class QtMobility::QGeoPositionInfo' has no member named 'dateTime'

  • Thanks. I actually can see that header file in the said folder. Previously I searched within the windows explorer. any ways

    And I didn't do any thing else than winding up and shutdown the laptop in office and turned it back on when I am home. And strange that the error I mentioned above is no more...

    Now I got the error what you have mentioned which I managed to fix with some code change at that line
    I changed the line 520 (where the error you mentioned is) with the following.
    [code]qulonglong timestamp = (qulonglong) info.timestamp().toTime_t() * 1000 + info.timestamp().time().msec();[/code]
    I think the code was older and has dateTime method has been deprecated.

    Any ways now there comes another error as follows
    [quote]:: error: No rule to make target \NokiaQtSDK\Symbian\SDK\epoc32\release\armv5\LIB\SensrvClient.dso', needed by\NokiaQtSDK\Symbian\SDK\epoc32\release\gcce\udeb\sensoreval.exe'. Stop.[/quote]

    Any clue?

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.