What are the symbian phones that support Qt\Qt Mobility?



  • I couldn't find any document with the list of devices and which Qt\Qt mobility version they support. Links, please?



  • Now Qt 4.6.3 available on device with symbian^3, symbian^1 (smartinstaller) and some other old devices.





  • Thanks.

    This is (almost) what I was looking for. It is still not clear to me if (or if not) Qt 4.7 can be installed on all the devices and if (or if not) mobility 1.1 is (or will be) available on any. I would imagine the information would be a little easier to find.

    Also I noticed on the first link that is is under the 4.7 but talks about the release 4.6:

    "Binary Compatibility

    As with every supported platform, we will strive to maintain application behavior and binary compatibility throughout the lifetime of the Qt 4.x series. However, due to the fact that Symbian support is newly added in 4.6.0, there is a slight possibility that minor corrections to the application binary interface (ABI) might be required in 4.6.1, in order to ensure compatibility going forward. Any such change will be clearly documented in the release notes for 4.6.1."



  • Quoting the text in the first link:
    Qt is designed to work on any device which runs one of the following versions of Symbian:
    Symbian Version
    S60 3.1
    S60 3.2
    S60 5.0 (Symbian ^1)
    And I remember seeing some guide to install Qt 4.7.0 on N8 also (i.e. Symbian^3).

    So this should cover at least any new or even "newish" Nokia device.
    I have understood the support for the QtMobility is pretty similar as the main Qt.

    I guess it was just mentioning the Qt 4.6.1 as possible binary breaking version on Symbian. But in general I would understand that in the way that the BC should be maintained in all 4.x.x versions.
    I.e. 4.6.1, 4.6.2, 4.6.3, 4.7.0, 4.7.1, etc...



  • All this is good info but doesn't answer my original question.

    In theory we can have Qt running on all them but what I wanted to know is as today how many devices could run a qt4.7 application using mobility 1.1. I assume the answer today is none (or maybe just the n8 and the n900) so the question is actually when we will have qt 4.7 and mobility 1.1 running on the other symbian phones.



  • fcrochik, today is none:) Only N900 has Qt4.7 but without QtMobility 1.1
    As I suggest, N8 will get new firmware after NewYear.
    Also, smartinstaller for symbian^1 works only with Qt 4.6



  • @Alexander, thanks! That is what I thought but couldn't validate.

    I believe that a public official qt/nokia document somewhere with this information should be available. It wouldn't hurt knowing how many devices on each "group" were produced/sold but I doubt this information will ever be published like this.

    All I am looking for is to know how many devices I can target using each tool set. Again, wouldn't hurt a little more detail like a matrix of features (e.g. not all devices that support qt version X with mobility version Y will support all the features - like camera, gps, sensors).



  • fcrochik, I think, at least all device with symbian^3, N900 and meego will have qt4.7 and qtmobility 1.1 later.



  • [quote author="Alexander Kuchumov" date="1291123649"]fcrochik, I think, at least all device with symbian^3, N900 and meego will have qt4.7 and qtmobility 1.1 later.[/quote]

    But the majority of devices in the market today is Symbian 3rd Edition and 5th Edition. Hope that somehow Qt 4.7 and updated Mobility API will be made available across these OS versions too.

    Or else its again a pain for developers to support these devices, although there is no binary break.



  • I don't know what Qt versions older S60's are up to. However..

    All S60v5 (Symbian^1) devices can install Qt4.7.1 and QtMobility 1.1.0 right now. I have done this on a 5800 and an N97.
    All Symbian^3 devices can install Qt4.7.0 right now. I have done this with N8 and E7.

    You are currently only allowed to deploy 4.6.3 on the Ovi Store though.

    Someone here mentioned you cannot use SmartInstaller with Qt4.7.0 and Symbian^3. Though, an application developer 'Digia' has managed to do so with their Flow'd application: http://www.flowd.com/web/common/mobile?nokia=1 Check the N8 download. This app uses QtQuick (4.7.0) on N8.



  • I had tried Qt Mobility 1.1 on 5800 and N97. But then am not sure if there could be any issues or not unless official confirmation comes in.

    Also have you tried QML on 5800 and N97. How is the performance.



  • Yeah I have tried many apps and games with QML on 5800/N97. Performance is surprisingly good.
    QML Sokoban, Flowd, Twitter, PictureFlow and even QML Web Browser are working nicely.

    I have a few apps I developed myself that are getting quite bloated but still run smoothly. I have a logging (notebook) application that is 940 lines of QML code now and probably at least 100 lines of extra C++ in the qmlviewer wrapper. Animations out the whazoo, yet smooth.

    Can't wait to work with OpenGL on E7/N8 :).



  • xsacha: thank you. That is the kind of detail I was hoping for...

    p.s. Are your applications open source? Do you make them available for maemo?



  • [quote author="xsacha" date="1291301318"]I don't know what Qt versions older S60's are up to. However..

    All S60v5 (Symbian^1) devices can install Qt4.7.1 and QtMobility 1.1.0 right now. I have done this on a 5800 and an N97.
    All Symbian^3 devices can install Qt4.7.0 right now. I have done this with N8 and E7.

    You are currently only allowed to deploy 4.6.3 on the Ovi Store though.

    Someone here mentioned you cannot use SmartInstaller with Qt4.7.0 and Symbian^3. Though, an application developer 'Digia' has managed to do so with their Flow'd application: http://www.flowd.com/web/common/mobile?nokia=1 Check the N8 download. This app uses QtQuick (4.7.0) on N8.[/quote]

    What does the flowd application do? I downloaded it from the above link and found it to be qtinstaller.sis with the fluid launcher example.



  • [quote author="fcrochik" date="1291302439"]p.s. Are your applications open source? Do you make them available for maemo?[/quote]

    Some are. My improvements on the Twitter app from SDK: "QML Twitter Symbian":http://www.4shared.com/file/F0OSfo1A/Twitter.html. But I haven't hosted the source anywhere yet. If you want I can send it. I don't have a Maemo device (or rather I haven't attempted) to test on so my sizing/coordinates might be out.

    [quote author="QtK" date="1291302705"]
    What does the flowd application do? I downloaded it from the above link and found it to be qtinstaller.sis with the fluid launcher example.[/quote]
    It's one of those geo-social apps where you chat to people and update your status or location (using GPS).
    Fluid launcher? That doesn't sound right. It gives me a Flowd_N8_installer.sis. It's just one .sis, isn't that just what SmartInstaller wrapper does?



  • [quote author="xsacha" date="1291303964"]
    [quote author="QtK" date="1291302705"]
    What does the flowd application do? I downloaded it from the above link and found it to be qtinstaller.sis with the fluid launcher example.[/quote]
    It's one of those geo-social apps where you chat to people and update your status or location (using GPS).
    Fluid launcher? That doesn't sound right. It gives me a Flowd_N8_installer.sis. It's just one .sis, isn't that just what SmartInstaller wrapper does?

    [/quote]

    I tried the download for 5800. However, Flowd_N8_installer.sis also seems to be the same. The size of the file is around 12 Mb. So it seems to be the qt installer sis file with fluid launcher demo.

    Can you provide the correct link. I would like to see a full fledged QML application running on 5800 or N97.



  • [quote author="QtK" date="1291304566"]
    Can you provide the correct link.[/quote]

    That's the correct link. I don't understand. You are seeing Fluid Launcher instead of Flow'd?



  • [quote author="xsacha" date="1291304892"]
    [quote author="QtK" date="1291304566"]
    Can you provide the correct link.[/quote]

    That's the correct link. I don't understand. You are seeing Fluid Launcher instead of Flow'd?[/quote]

    No when I am downloading it. I get a sis file named qt_installer.sis. On installing it it turns out to be Qt 4.7.1 binaries with fluid launcher.

    Just try downloading the sis file and installing it. Its pointing to wrong sis file.



  • It might be your web browser?
    If you click 'Nokia Touch', you get two steps:

    1. Download Qt (which is the file you seem to be getting, qt_installer.sis)
    2. Download Flowd. flowd_bundle_29_9_2010.sis

    If you select 'Nokia N8' however, you just get Flowd_N8_installer.sis.

    If you can't get that working, here's my Twitter Search application:
    http://www.wikiupload.com/3TXMITTCPC8UJJY
    Works on all Symbian^1^ and Symbian^3^.



  • Yes might be the download is supported only from a device and not from PC browser.



  • I downloaded it from the PC browser. Both the Touch version and the N8 version work fine.

    To confirm, you tried:
    flowd_bundle_29_9_2010.sis for 5800
    and Flowd_N8_installer.sis for N8?

    The Flowd_N8_installer will be 12MB and will include Qt but this doesn't mean it doesn't include the application too.

    If you are receiving qt_installer.sis instead, try a different web browser.

    Did you try the twitter app?



  • [quote author="tamhanna" date="1291461287"]Hi,
    if you are looking for the Ovi list - a somewhat recent one is here:
    http://tamss60.tamoggemon.com/2010/11/10/nokia-now-supports-19-qt-devices-on-ovi/

    ltomuta usually tweets the URL for the list once a week or so - so follow him on Twitter for updates![/quote]

    Great, thanks!

    It can't be too hard to get nokia to create an official list with links to the phone specs and details about the supported features, can it? I would imagine should be on the first page of any document trying to get more developers on board! If one exists it is anything but easy to find.



  • In here:
    http://wiki.forum.nokia.com/index.php/Nokia_Smart_Installer_for_Symbian
    It mentions that N96 and AT&T 6650 don't support SmartInstaller.



  • I'd say AT&T probably don't care at all. So you won't see the firmware update. I think those two devices are just lost causes.

    There isn't any others that don't get Qt is there?



  • It's not sold in my country. Nokia pulled it from the shelves after 6 months. In fact, they were still selling N95 when they took off N96.

    The bling edition will work. It's only AT&T branded, as the wiki suggests.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.