Developing for Windows CE



  • Hello everyone,

    I'm new to Qt and I started to write applications for mobile devices. I've already tested them on Symbian, but I liked to write apps for Windows CE. So I downloaded the Qt libraries (http://qt.nokia.com/downloads/) 4.8.2 for Windows CE, but I'm not sure what to do with them. I tried to install a new Qt version in my Qt creator, but i didn't found a qmake.exe in the folder.

    Really, I have already searched the web, and it seems like I've visited every single Qt-Website twice, but I still don't know, where to get such a qmake-file. I'd be thankful, if someone gave me an answer



  • Well, ok, I moved a little forward, but I still have problems:

    I installed Visual Studio 2010 Professional and the Qt-Add-In. Moreover, I downloaded the commercial version of the Qt-libraries for Windows CE.

    Now, I tried to write an application for my device (Windows Embedded CE 6.0), but as I had the wrong Qt-Version, it didn't work. So I tried to change the version over Qt --> Qt Options. There I tried to add a new version, but it told me, that qmake wasn't found. I looked into the bin-folder, and it really wasn't there.

    Now, the last thing I tried was this:
    http://doc.qt.nokia.com/4.7-snapshot/install-wince.html

    I followed the steps, and first it worked fine, but at step 3, when I enter "configure -platform win32-msvc2010" it told me first that it cannot find the license ".qt-license" in C:\Users<Myname>. So I thought just to save a new file called ".qt-license" with the license key for the commercial library written in it. But this didn't work either. Now it says: "License file does not contain proper license key.0"

    Now, I really don't know, what to do. Does anyone have an idea?



  • I'm a complete newb to QT, but have done a fair bit of CE development, and AFAIK Visual Studio 2010 doesn't support CE at all. You might have more luck basing your efforts on top of VS 2008 Professional, which definitely does.



  • Hmmm... I've already thought of downloading VS 2008, well, it looks like I have to try it this way. Thanks!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.