Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[Solved] Where is Meego Emulator in windows?



  • When install the Qt SDK 1.2, I have the opinion to installl Meego emulator. But even if I select it, I can't find where is it after installation? So , how to get it in Qt Creator?



  • I've written a wiki page on the subject some time ago.
    "Link":http://qt-project.org/wiki/How_to_use_the_Meego_1.2_Harmattan_emulator
    If you find out that some things have changed, please add your experience to the wiki or in this topic as you like.



  • Thanks. Researching on it.



  • With Qt SDK, I have installed through "help menu > Start updater > package manager:

    • Experience ->All harmattan components;
    • Development Tools -> All harmattan components(including emulator PR1.0, PR1.1, PR1.2, 1.7G in size)

    But I still can't find how to get the emulator in the creator. Is there any other issue?



  • Can you elaborate a little more please? What part of the wiki is not up to date anymore? What options did you not find?
    (at this moment i can't test it myself, but i will try tomorrow)



  • I just tested it out and it works for me.
    I made some minor changes to the wiki page (see link above)

    Maybe your hardware is not sufficient to run the emulator. Don't forget this is a very slow process compared to the simulator. Why not use the simulator? It has a N9 simulation too.



  • Great Thanks. The simulator, you mean QT simulator with the N9 looks? It is ok for my application, but it fails on N9 device with "THIS":http://qt-project.org/forums/viewthread/15518/ error. - This is really frustrated.

    When it is on Qt1.2. a few things has changed, for example,

    1. "custom" in "Qt Creator > help menu > Start updater" can be found, but "packet manager" instead.
    2. "Qt Creator > menu options > Maemo > tab Qemu settings" can't be found, but "linux device>Meego QMenu settings"
    3. I've installed all components in "Harmattan Emulator", including PR1.0 (version 1.2011.34-1), PR1.1(version 2.2011.39-5) and PR1.2(3.2012.07-1)
    4. I've installed Experimental->Harmmattan which contains only "Instrumentation Dashboard"

    How ever in your wiki, "Project Wizard" section, I can't find the "Harmattan" in step1.

    I can't understand why Nokia will "bury" such things which makes the dev efficiency lower and lower. However, viva N9 - Some people pushes it, yet other people in this company pull it.

    Can you try it on Qt SDK 1.2, please?
    Or Can I get your gmail ... For me, that is usersbbs@gmail.com.



  • Thanks for the feedback

    I will change the version info on the wiki since it has changed as you posted.

    [edit : wiki changed]



  • bq. Great Thanks. The simulator, you mean QT simulator with the N9 looks? It is ok for my application, but it fails on N9 device with THIS [qt-project.org] error. – This is really frustrated.

    The simulator is meant for testing in a simulator environment, not on the real device. You need the Harmattan toolchain after you connected the device.
    "See the Qt Creator manual for more details":http://doc.qt.nokia.com/qtcreator-2.4/creator-developing-meego.html



  • Yes. I have worked it out. Thanks for the help.

    As a supplementary,

    1. In the wiki, section "Project Wizard", for step one, select "Harmattan Target (Qt SDK) release or debug".
    2. Then, after the emulator is installed, please refer "THIS":http://doc.qt.nokia.com/qtcreator-2.4/creator-developing-meego.html for section "Configuring Connections to Harmattan Devices". Where you can choose using "Emulator" rather than "Hardware Device". Then you can connect to the eumlator.
    3. Start the emulator first. Then start running/debugging the project. You will get your application on the emulator.



Log in to reply