[SOLVED]qmake :: error when used for target i.MX



  • Hi,

    Having built Qt for Embedded [Qt_Everywhere_Opensource] on i.MX5X successfully, an Application has been tried on Qt Creator IDE [from Qt_SDK_4.8.0] on Host-PC, with the build, qmake being done well.

    The application binary has been generated with a makefile, that uses the native-gcc as the work is being done on Host. The binary has been successfully run on the Qt_Simulator.

    Now that, I wanted to try this on Target, I did this

    Cross-Compile [ Using arm-none-linux-gnueabi- YYY ] the Project files with the qmake binary for i.MX5X

    post4pavan@ubuntu:/usr/local/Trolltech/Qt-target-version/bin$ ./qmake /home/post4pavan/Work/hi/hi.pro

    Failure to open file: /usr/local/Trolltech/Qt-target-version/bin/Makefile
    Unable to generate makefile for: /home/post4pavan/Work/hi/hi.pro

    Please Suggest!


  • Moderators

    You are trying to create your build system in /usr/local/Trolltech/Qt-target-version/bin. If you don't happen to be root (which would be stupid, root should not be used to build!), then this has to fail.

    Try running "/usr/local/Trolltech/Qt-target-version/bin/qmake ../hi/hi.pro" in /home/post4pavan/Work/hi-build instead. Does that work?



  • Hi, Tobias Hunger, thank you!

    Yeah! that solution worked! and I have solved it.
    Foolish on my part to forget the basic that we should not build with in the /usr/local/....../Trolltech/.. root area.

    Thank You once again...!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.