[SOLVED]Simple QML application run but no view ( anything displayed ) on Symbian Anna operated device



  • Hello.

    I am building applications. Recently I made simple qml application with next .pro file:

    @# Add more folders to ship with the application, here
    #CONFIG += release qt-components
    QT += gui declarative

    Additional import path used to resolve QML modules in Creator's code model

    QML_IMPORT_PATH = qml/common

    symbian {
    #message(Symbian)

    TARGET.UID3 = 0xE19618FC
    #DEFINES += USE_DEVSOUND

    platform_qml.source = qml/symbian
    platform_qml.target = qml
    QML_IMPORT_PATH += qml/symbian

    INCLUDEPATH += /epoc32/include/mw

    }

    VERSION = 1.2.0

    Smart Installer package's UID

    This UID is from the protected range and therefore the package will

    fail to install if self-signed. By default qmake uses the unprotected

    range value if unprotected UID is defined for the application and

    0x2002CCCF value if protected UID is given to the application

    #symbian:DEPLOYMENT.installer_header = 0x2002CCCF

    Allow network access on Symbian

    #symbian:TARGET.CAPABILITY += NetworkServices

    If your application uses the Qt Mobility libraries, uncomment the following

    lines and add the respective components to the MOBILITY variable.

    CONFIG += mobility

    MOBILITY +=

    Add dependency to symbian components

    #CONFIG += qtquickcomponents

    The .cpp file which was generated for your project. Feel free to hack it.

    SOURCES += main.cpp

    Please do not modify the following two lines. Required for deployment.

    include(qmlapplicationviewer/qmlapplicationviewer.pri)
    qtcAddDeployment()@

    The project contains 1 qml file and main.cpp and also qmlapplicationviewer module that is necessary to display qml ui.

    I built it for Linux and it runs and displays the qml ui declared OK under ubuntu.

    I need to run it on mobile device Symbian Anna operated - Nokia C700 has installed on it QtQuickComponents , QmlViewer , Qt 4.7.4 , QtMobility from .sis files.

    I already built for that device QtDrumkit application and several another that uses qml and they run ok on the device.

    But when I build the simple qml application mentioned above and create self-signed .sis file as for previous applications and deploy it to the device - the application is succes. installed but when I run it I see anything displayed - black screen .

    Maybe images that I use in QML items wasn't added ? How to add the images?
    What could be the problem/issue here?
    Does anybody know where there is a mistake during compiling and deploying that simple qml application ?

    Thank you very much in advance for your help.



  • Recently solved the issue - images was added to the project and it was built - > ui displayed ok on the device. But when I added images to resource file than ui wasn't displayed , why? Yet dn.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.