Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Design Studio form editor did not working.



  • I downloaded a latest qt installer for windows and installed only the design tools. I created a new 'qt quick application-launcher' project by design studio and chose qt6 and material dark style. I just ran the project right after created, and a window was opened with nothing but white background. What I expected was a window with a text on gray background. I checked the form editor and then i saw nothing on the editor. I am not an English user, it's hard to explain what it happened, so I took some screen shots.

    https://photos.app.goo.gl/MQPu9UhkcwQxsUHF9
    This is a shot of empty form editor in ds(design studio).

    https://photos.app.goo.gl/RN7fQvMeaVbdGBAZ6
    This is a shot of the window when I ran the project.

    https://photos.app.goo.gl/Wi1wAvv2y4QBWFUg9
    This is a shot of some messages when I ran the project.

    I searched with 'Failed to build graphics pipeline state', and got a hint from stackoverflow that it may works if add an env variable 'QT_QUICK_BACKEND' of value 'software'. So I did it and it really worked.

    https://photos.app.goo.gl/KiuekrZ5vTcsYiir6
    This is a shot to add a env variable.

    https://photos.app.goo.gl/CvzHtcksv17wShS98
    This is a shot of the window after adding env.

    BUT the form editor of ds still do not work, empty.
    I need some help to fix the problem.

    https://photos.app.goo.gl/pH8wrmWmfNQDn3Yu9
    I am using Qt Design Studio 2.2.2 and Windows 10.

    Please let me know how to fix it or what I mistake. Thank you sir.



  • I found an old post not resolved. https://forum.qt.io/topic/121959/problem-with-design-studio-and-qml
    Surprisingly, I am in 2021, and no one has responded to this post for about a year and it hasn't been resolved either. It seems no one knows the solution of the problem that the form editor doesn't show anything.

    Unbelievably, the design studio isn't showing any errors about the problem with the form editor. So I have absolutely no idea what is causing this problem.


  • Lifetime Qt Champion

    @EbyZero Did you check Qt bug tracker (https://bugreports.qt.io/secure/Dashboard.jspa)? If nobody filed a bug for this issue you can do.



  • I had the same problem (Qt Design Studio 2.3.1), and didn't find a way to fix it. Even if I set the width and height properties of the rectangle (in my case) in the Form Editor it looked like the width and height were 0. I think this might have been a problem caused by the initial project settings for the width and height. I set them to 640 x 480, but may have set the layout to portrait instead of landscape.

    I created a new project and made sure I used standard sizes and layout and I was able to see the rectangle.

    I'll see if there is a way to reproduce this and submit a bug since I didn't see one for this problem.