Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

How to solve "STL1000: Unexpected compiler version, expected Clang 11.0.0 or newer"?



  • Hello all, hope all are doing well, I am new in QT Development and using "QT for MCU 1.9", therefore, I am exploring some available example to understand how everything is organized in QT. I don't know what happens, when I try to run some examples then some of them runs perfectly without any error while some of them showing this error..":-1: error: STL1000: Unexpected compiler version, expected Clang 11.0.0 or newer"..Please help...I am attaching all the installed components Pictures...Thanksm_wizard.PNG visual_studio.jpg


  • Lifetime Qt Champion

    @Shrikant-Vaishnav Since Qt for MCUs is a commercial product you can ask QtCompany directly for support.


Log in to reply