Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

i cant build x64



  • Here's my param:
    configure.bat -mp -release -static -static-runtime -confirm-license -nomake tools -nomake examples -prefix "C:\Qt\QtStatic\x64\5.15.2\msvc"

    i am using x64 native tools VS 2019

    i get this error:

            link /NOLOGO /DYNAMICBASE /NXCOMPAT /OPT:REF /INCREMENTAL:NO /SUBSYSTEM:CONSOLE "/MANIFESTDEPENDENCY:type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' publicKeyToken='6595b64144ccf1df' language='*' processorArchitecture='*'" /VERSION:5.15 /MANIFEST:embed /OUT:..\..\bin\meshdebug.exe @C:\Users\Chriilz\AppData\Local\Temp\meshdebug.exe.14940.1907.jom
       Creating library ..\..\bin\meshdebug.lib and object ..\..\bin\meshdebug.exp
    jom: C:\qt-everywhere-src-5.15.2\Makefile [module-qtmultimedia-make_first] Error 2
    jom: C:\qt-everywhere-src-5.15.2\Makefile [module-qt3d-make_first] Error 2
    

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You need to provide the lines above where the failure occurred.



  • @Code5yndicate said in i cant build x64:

    DYNAMICBASE

    Thanks for the reply sir. thats the error before the jom stops


  • Lifetime Qt Champion

    There's more to it, please look upper in the log.

    You can also try to force a single thread execution to help pinpoint the error.



  • i got this warning before i run jom sir, do you think this affect the compilation? do i need to fix it first?

    WARNING: QDoc will not be compiled, probably because libclang could not be located. This means that you cannot build the Qt documentation.
    
    Either ensure that llvm-config is in your PATH environment variable, or set LLVM_INSTALL_DIR to the location of your llvm installation.
    On Linux systems, you may be able to install libclang by installing the libclang-dev or libclang-devel package, depending on your distribution.
    On macOS, you can use Homebrew's llvm package.
    On Windows, you must set LLVM_INSTALL_DIR to the installation path.
    
    WARNING: Python version 2 (2.7.5 or later) is required to build QtWebengine.
    
    WARNING: Python version 2 (2.7.5 or later) is required to build QtPdf.
    
    WARNING: QtWebEngine will not be built.
    
    WARNING: QtPdf will not be built.
    

  • Lifetime Qt Champion

    No, you can't build QtWebEngine statically anyway.

    What configure line did you use ?
    Did you restart the build with a single thread to see where it failed ?



  • How about the libclang thing sir? is it okay?


  • Lifetime Qt Champion

    You will lose qdoc which is not important since if you really need it, you can use the one from the pre-built packages.



  • Here's my config log sir

    https://pastebin.com/sTf1Wtz4


  • Lifetime Qt Champion

    You should also disable the tests build.

    From the looks of it, the configuration succeeded.

    As I already suggested several times: start you build using a single thread to see exactly where it fails.



  • @SGaist Sir the problem has fixed but another problem from JOM INSTALL process.

    qmake_Qt3D_Animation.cpp] Error 1
            1 file(s) copied.
    jom: C:\qt-everywhere-src-5.15.2\qt3d\src\quick3d\imports\animation\Makefile.importsanimation [release-install] Error 2
    jom: C:\qt-everywhere-src-5.15.2\qt3d\src\Makefile [sub-quick3d-imports-animation-install_subtargets] Error 2
    jom: C:\qt-everywhere-src-5.15.2\qt3d\src\Makefile [sub-quick3d-imports-extras-install_subtargets] Error 2
    jom: C:\qt-everywhere-src-5.15.2\qt3d\Makefile [sub-src-install_subtargets] Error 2
    jom: C:\qt-everywhere-src-5.15.2\Makefile [module-qt3d-install_subtargets] Error 2
    

    full log:

    https://pastebin.com/SFaz2kJC


  • Lifetime Qt Champion

    It's not the build log.

    Look for the error 1 lines.

    Before going further, which modules do you need exactly ?



  • @SGaist Okay sir i am trying to skip 3d now. i will let you know if its succeed



  • The error happens again in JOM process sir, not on install process. i dont know what happen. i can build QT in 32 bit but not on 64 :'( @SGaist


  • Lifetime Qt Champion

    Again without the adequate information, there's no way to find what your issue is.



  • Sir already built it. just skipped 3d. thankyou


Log in to reply