Qt6 topics merged with General

QtLocation doesn't compile correctly with qmake -r and make

  • Hello everyone, please can you help me to overcome this big problem.
    It's been a long time and I tried to compile the QtLocation module with qt 6.0.3 (Mingw 8.1.0 64 bits), but it's not work.
    The process I follow is :
    download qtlocation library from GitHub (I tried for 10 last versions).
    Run qt 6.0.3 (Mingw 8.1.0 64 bits) cmd.
    Go to the qtlocation folder.
    Run qmake or run qmake -r
    run mingw32-make or run make
    run mingw32-make install or run make install


    C:\Users\Haoudi\Downloads\qtlocation-dev\src\positioning\qgeoareamonitorsource.cpp:41:10: fatal error: QGeoAreaMonitorSource: No such file or directory
    #include <QGeoAreaMonitorSource>
    compilation terminated.
    make[3]: *** [Makefile.Release:1793: .obj/release/qgeoareamonitorsource.o] Error 1
    make[3]: Leaving directory 'C:/Users/Haoudi/Downloads/qtlocation-dev/qtlocation-shadow-build/src/positioning'
    make[2]: *** [Makefile:45: release] Error 2
    make[2]: Leaving directory 'C:/Users/Haoudi/Downloads/qtlocation-dev/qtlocation-shadow-build/src/positioning'
    make[1]: *** [Makefile:132: sub-positioning-make_first] Error 2
    make[1]: Leaving directory 'C:/Users/Haoudi/Downloads/qtlocation-dev/qtlocation-shadow-build/src'
    make: *** [Makefile:52: sub-src-make_first] Error 2


    I follow the same process to compile the MQTT library, and it's work correctly.

  • Lifetime Qt Champion


    What if you use cmake ?

Log in to reply