Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Creator - "Plugin Loader Messages" at startup



  • (I have already asked this in the General and Desktop forum without a response but perhaps this Tools forum is more appropriate.)

    Qt Creator was prompting me to update so I did so the other day. However, every time I start it since then I get a "Plugin Loader Messages" popup with the following content:

    9022a6ae-0a97-4ae9-b1ec-0d6b7f7e65b3-image.png

    So far it doesn't seem to have caused any issue other than being annoying but I don't know if it might be a sign of a more serious issue that needs to be dealt with.

    Please does anyone have any idea what the issue might be and if there is anything I can do to fix it.

    Thanks.


  • Moderators

    Please start the maintenance tool and check whether there are any updates pending.

    If not, can you

    • open the components.xml file right beside the MaintenanceTool executable
    • search for 'qt.tools.qtcreator.enterprise.plugins' and
    • post the version number that's recorded there here?

  • Lifetime Qt Champion

    @Bob64 I don't know why this happens, but you can disable plug-ins in Help/About Plugins


  • Moderators

    Please start the maintenance tool and check whether there are any updates pending.

    If not, can you

    • open the components.xml file right beside the MaintenanceTool executable
    • search for 'qt.tools.qtcreator.enterprise.plugins' and
    • post the version number that's recorded there here?


  • @kkoehne Thanks - I thought I had already tried this but there was a recent plugins update pending. Perhaps I had missed it as it was hidden among a list of zero sized updates to things like Qt Charts. I am using Qt 5.9.6 so would not expect any of these things to be updated now.

    Anyway the update has now fixed the issue so thank you.


Log in to reply