Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Compiling/building custom CMake/.pro C++ application in Qt Creator with Qt 5.15.0, 5.15.12 for WebAssembly, Emscripten configured, but compilation and build halts. How to resolve?



  • Re: How to set up the Qt for WebAssembly compiler ?

    Hi,

    Having installed and configured Emscripten, please see pictures, when running build in Qt Creator, after configured, why ABI detection failed:

    ABI:
    unknown-unknown-unknown-unknown-unknown

    and why when launching build in Qt Creator, next:

    /opt/Qt/5.15.2/wasm_32/plugins/platforms/libqwasm.a: error adding symbols: File format not recognized
    clang-13: error: linker command failed with exit code 1 (use -v to see invocation)

    with looking good Emscripted configured:
    C compiler:/opt/Qt/emsdk/upstream/bin/clang
    C++ compiler:/opt/Qt/emsdk/upstream/bin/clang++

    for second Emscripten version other building error appears.

    It is needed to resolve it and to attain full compilation and building for Web Assembly(generate all the output files with .js, etc.) as this topic numerously tried before by many people and not yet fully solved:

    https://forum.qt.io/topic/121267/qt-webassembly-compiler-error/4
    https://community.esri.com/t5/arcgis-runtime-sdk-for-qt/qt-webassembly-issue/m-p/272329
    https://forum.qt.io/topic/117338/webassembly-build-fails/2
    https://forum.qt.io/topic/117338/webassembly-build-fails/2
    https://www.coder.work/article/7128602

    Kind Regards,
    Coder.
    ![22_1616942742017_Emcpp3.png](Uploading 100%) ![21_1616942742017_Emcpp4.png](Uploading 100%) ![20_1616942742013_WebAssemblyConfigurationAttempts.png](Uploading 100%) ![19_1616942742012_Emcpm2.png](Uploading 100%) ![18_1616942742012_Emcpp2.png](Uploading 100%) ![17_1616942742012_Screenshot from 2021-03-26 16-21-15.png](Uploading 100%) ![16_1616942742011_Screenshot from 2021-03-26 16-31-14.png](Uploading 100%) ![15_1616942742011_Screenshot from 2021-03-26 16-36-55.png](Uploading 100%) ![14_1616942742010_Screenshot from 2021-03-26 16-44-09.png](Uploading 100%) ![13_1616942742008_Screenshot from 2021-03-26 16-44-14.png](Uploading 100%) ![12_1616942742007_Screenshot from 2021-03-26 16-44-17.png](Uploading 100%) ![11_1616942742007_Screenshot from 2021-03-26 16-44-23.png](Uploading 100%) ![10_1616942742007_Screenshot from 2021-03-26 16-44-29.png](Uploading 100%) ![9_1616942742007_Screenshot from 2021-03-28 16-45-18.png](Uploading 100%) ![8_1616942742006_Screenshot from 2021-03-28 16-39-30.png](Uploading 100%) ![7_1616942742006_Screenshot from 2021-03-28 16-39-46.png](Uploading 100%) ![6_1616942742006_Screenshot from 2021-03-28 16-41-13.png](Uploading 100%) ![5_1616942742006_Screenshot from 2021-03-28 16-41-19.png](Uploading 100%) ![4_1616942742005_Screenshot from 2021-03-28 16-43-24.png](Uploading 100%) ![3_1616942742005_Screenshot from 2021-03-28 16-43-33.png](Uploading 100%) ![2_1616942742005_Screenshot from 2021-03-28 16-43-37.png](Uploading 100%) ![1_1616942742004_Screenshot from 2021-03-28 16-45-06.png](Uploading 100%) ![0_1616942742003_Screenshot from 2021-03-28 16-45-12.png](Uploading 100%)

    Screenshot from 2021-03-28 16-43-24.png
    WebAssemblyConfigurationAttempts.png Emcpm2.png Emcpp2.png ![4_1616942866995_Screenshot from 2021-03-28 16-45-18.png](Uploading 100%) ![1_1616942866993_Screenshot from 2021-03-28 16-41-13.png](Uploading 100%) ![0_1616942866993_Screenshot from 2021-03-28 16-41-19.png](Uploading 100%)Screenshot from 2021-03-26 16-31-14.png


Log in to reply