Please nominate your Qt Champions for 2021!

webassembly build fails

  • ubuntu 20.04
    Qt 5.15.0
    emscripten 1.39.8
    I followed the instructions here: to install and activate emscripten 1.39.8 and installed Qt 5.15.0 open source from the Qt downloads page.
    I created a qt quick project but could not select the webassembly kit (grayed out)
    Under Manage kits (webassembly) I could see that the compilers were empty (<No compiler>)
    I tried to add them manually: I added emsdk/upstream/bin/clang++ for the c++ compiler and emsdk/upstream/bin/clang for the C compiler.
    back on the kits page I was now able to add the webassembly C++ compiler, but not the C compiler.
    I tried to build anyway and get this error::-1: error:

    Qt/5.15.0/wasm_32/plugins/platforms/libqwasm.a: error adding symbols: file format not recognized

    Can anybody point me in the right direction for fixing this?

  • @amphi u can try to put emscripten configuration file in home directory (~.emscripten) and Qt creator should be able to find emscripten automatically. But I did it on Win10, might be the same issue for ubuntu ( )

  • @amphi Hello,

    I know it is quite old, but I have the same issue.
    Did you solve it eventually?

    Thank you

Log in to reply