[Solved] Weird font behavior in Linux ARM



  • I have a UI Designer form with a mixture of command buttons and text labels. They all have the same font and the same size. I do my development on a PC with a VirtualBox Linux environment. When I run it in that environment, everything shows up fine. On the other hand, when I transfer the application to the target environment (Linux ARM 9) and run it, one of the command buttons and one of the text fields display in a smaller point size than the rest. Has anyone else ever seen this kind of behavior?



  • Yes, same thing happens when using pure QtWidgets project on N9. Must set app font to 20pts ..



  • For anyone who might have the same problem in the future, I found out what was happening. While the file looked good in Designer, when I looked at the .ui file with a text editor, I noticed that the font definitions were incomplete for some of the QLabels and QPushButtons. Even though they were defined in Designer, they lost those definitions when it was translated into the .ui file. I had to use the text editor to copy the correct font properties into the definitions for the problem elements.


  • Moderators

    Did you consider filing a bug report on JIRA?
    You should certainly do so, when the problem is reproducable.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.