Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

The CDB process terminated



  • I have successfully compiled a github project using Qt Creator 4.13 and Qt 5.12. , everything on Win 10 64bit.

    But when I try to start debugging of startup project:

    a02ee9a4-3a7e-45ce-aa00-84f4855b2c90-image.png

    after few seconds I got:

    bf8ff51c-1ce9-4351-a91a-14b0f6496cee-image.png

    I really need to debug the project ... canyou help me a little bit ?



  • @Flaviu-0
    I thought we were discussing this in your https://forum.qt.io/topic/121849/vcruntime140_app-dll-was-not-found/5 ? How does this relate to that?

    I suggested there that you at least try running the CDB outside of Qt Creator, how did that go?



  • In that post I wrote about two problems in did, with vcruntime140_app.dll and this one, The CBT process terminated.

    The first problem is solved and I create another thread for second problem. Maybe I shouldn't did that.

    Regarding your advice: "try running the CDB outside of Qt Creator"

    I don't know what is mean, I haven't worked with Qt until now. And I searched about CDB info:

    52bebd53-144f-4d87-8347-4b433a6a48c6-image.png

    ee2aa3fe-b932-4662-84ef-10f69dcbdd60-image.png

    Found nothing. How can I run CDB outside of Qt creator ?

    Thank you for your patience.



  • @Flaviu-0
    I have never used CDB. I just know it's a Windows debugger supplied by MS, usually as part of Windows SDK. If you wish to find about it, Google for cdb debugger (not just cdb, that turns out to be Caribbean Development Bank ;-) ). There are also plenty of hits for qt cdb process terminated.

    That's all I know. I will leave for others to help further.



  • That CDB exe I found it in C:\Program Files (x86)\Windows Kits\10\Debuggers\x64

    eaaa7bae-f28c-467c-a1ee-f77f3336ead5-image.png

    But I don't know what I should do further ...

    P.S. Here is my autodetected CDB:

    2a581e3c-4511-447c-9613-e635b47d5a30-image.png


  • Lifetime Qt Champion

    Hi @Flaviu-0,

    Can you debug a minimal, "hello world" like program from Qt Creator with CDB?

    That has to work first to prove everything is set up correctly.

    Regards



  • You can run the program, then attachs it. Maybe it can work.



  • @aha_1980 Yes, I have created a simple Qt desktop project, and I can debug it without any problem. But not my real project.



  • @spobit The compiled real project is running only if I start it from Windows Explorer, if I start it from Debugger, I got the error from the first post.



  • @aha_1980 But really I don't know if I debug the hello world app with CDB or with something else :) ... I can go through the code step by step with F9/F10, that's all I know.


  • Lifetime Qt Champion

    @Flaviu-0

    you can open View > Views > Debugger Log and see what is printed there.

    Can you Run your real app from Creator (i.e. without debugger)?

    Regards



  • Let me give another information. In the real app case, when I hit F5, before starting the debugger, I see in Application Output:

    ...
    ...
    [ 95%] Built target edit_measure
    [ 96%] Built target edit_mutualcorrs
    [ 96%] Built target edit_paint
    [ 97%] Built target edit_point
    [ 98%] Built target edit_pickpoints
    [ 99%] Built target edit_referencing
    [ 99%] Built target edit_select
    [100%] Built target edit_quality
    Install the project...
    -- Install configuration: "Debug"
    -- Up-to-date: D:/Project/MyProject/src/install_debug/shaders/Cook-Torrance.frag
    -- Up-to-date: D:/Project/MyProject/src/install_debug/shaders/Cook-Torrance.gdp
    -- Up-to-date: D:/Project/MyProject/src/install_debug/shaders/Cook-Torrance.vert
    -- Up-to-date: D:/Project/MyProject/src/install_debug/shaders/Hatch.frag
    -- Up-to-date: D:/Project/MyProject/src/install_debug/shaders/Hatch.gdp
    -- Up-to-date: D:/Project/MyProject/src/install_debug/shaders/Hatch.vert
    ...
    ...
    

    I guess that is not normal ... right ?



  • @aha_1980
    I opened that log, I and see:

    MyProject loaded: MyProject.exe
    MyProject loaded: ntdll.dll
    MyProject loaded: C:\WINDOWS\System32\KERNEL32.DLL
    MyProject loaded: C:\WINDOWS\System32\KERNELBASE.dll
    MyProject loaded: C:\WINDOWS\System32\SHELL32.dll
    MyProject loaded: C:\WINDOWS\System32\ucrtbase.dll
    MyProject loaded: C:\WINDOWS\System32\cfgmgr32.dll
    MyProject loaded: C:\WINDOWS\System32\shcore.dll
    MyProject loaded: C:\WINDOWS\System32\msvcrt.dll
    MyProject loaded: C:\WINDOWS\System32\RPCRT4.dll
    MyProject loaded: C:\WINDOWS\System32\combase.dll
    MyProject loaded: C:\WINDOWS\System32\bcryptPrimitives.dll
    MyProject loaded: C:\WINDOWS\System32\windows.storage.dll
    MyProject loaded: C:\WINDOWS\System32\msvcp_win.dll
    MyProject loaded: C:\WINDOWS\System32\sechost.dll
    MyProject loaded: C:\WINDOWS\System32\advapi32.dll
    MyProject loaded: C:\WINDOWS\System32\profapi.dll
    MyProject loaded: C:\WINDOWS\System32\powrprof.dll
    MyProject loaded: C:\WINDOWS\System32\UMPDC.dll
    MyProject loaded: C:\WINDOWS\System32\shlwapi.dll
    MyProject loaded: C:\WINDOWS\System32\GDI32.dll
    MyProject loaded: C:\WINDOWS\System32\win32u.dll
    MyProject loaded: C:\WINDOWS\System32\gdi32full.dll
    MyProject loaded: C:\WINDOWS\System32\USER32.dll
    MyProject loaded: C:\WINDOWS\System32\kernel.appcore.dll
    MyProject loaded: C:\WINDOWS\System32\cryptsp.dll
    MyProject loaded: C:\WINDOWS\SYSTEM32\GLU32.dll
    MyProject loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5Networkd.dll
    MyProject loaded: C:\WINDOWS\System32\WS2_32.dll
    MyProject loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5OpenGLd.dll
    MyProject loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5Widgetsd.dll
    MyProject loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5Guid.dll
    MyProject loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5Xmld.dll
    MyProject loaded: C:\WINDOWS\SYSTEM32\OPENGL32.dll
    MyProject loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5Cored.dll
    MyProject loaded: C:\WINDOWS\SYSTEM32\MSVCP140D.dll
    MyProject loaded: C:\WINDOWS\SYSTEM32\VCRUNTIME140D.dll
    MyProject loaded: C:\WINDOWS\SYSTEM32\ucrtbased.dll
    MyProject loaded: C:\WINDOWS\SYSTEM32\ucrtbased.dll
    ERROR: Process crashed
    Debugger finished.
    

    and

    ************* Path validation summary **************
    Response                         Time (ms)     Location
    Error                                          ""
    Symbol search path is: ""
    Executable search path is: 
    Module loaded: MyProject.exe
    Module loaded: ntdll.dll
    Module loaded: C:\WINDOWS\System32\KERNEL32.DLL
    Module loaded: C:\WINDOWS\System32\KERNELBASE.dll
    Module loaded: C:\WINDOWS\System32\SHELL32.dll
    Module loaded: C:\WINDOWS\System32\ucrtbase.dll
    Module loaded: C:\WINDOWS\System32\cfgmgr32.dll
    Module loaded: C:\WINDOWS\System32\shcore.dll
    Module loaded: C:\WINDOWS\System32\msvcrt.dll
    Module loaded: C:\WINDOWS\System32\RPCRT4.dll
    Module loaded: C:\WINDOWS\System32\combase.dll
    Module loaded: C:\WINDOWS\System32\bcryptPrimitives.dll
    Module loaded: C:\WINDOWS\System32\windows.storage.dll
    Module loaded: C:\WINDOWS\System32\msvcp_win.dll
    Module loaded: C:\WINDOWS\System32\sechost.dll
    Module loaded: C:\WINDOWS\System32\advapi32.dll
    Module loaded: C:\WINDOWS\System32\profapi.dll
    Module loaded: C:\WINDOWS\System32\powrprof.dll
    Module loaded: C:\WINDOWS\System32\UMPDC.dll
    Module loaded: C:\WINDOWS\System32\shlwapi.dll
    Module loaded: C:\WINDOWS\System32\GDI32.dll
    Module loaded: C:\WINDOWS\System32\win32u.dll
    Module loaded: C:\WINDOWS\System32\gdi32full.dll
    Module loaded: C:\WINDOWS\System32\USER32.dll
    Module loaded: C:\WINDOWS\System32\kernel.appcore.dll
    Module loaded: C:\WINDOWS\System32\cryptsp.dll
    Module loaded: C:\WINDOWS\SYSTEM32\GLU32.dll
    Module loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5Networkd.dll
    Module loaded: C:\WINDOWS\System32\WS2_32.dll
    Module loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5OpenGLd.dll
    Module loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5Widgetsd.dll
    Module loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5Guid.dll
    Module loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5Xmld.dll
    Module loaded: C:\WINDOWS\SYSTEM32\OPENGL32.dll
    Module loaded: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\Qt5Cored.dll
    Module loaded: C:\WINDOWS\SYSTEM32\MSVCP140D.dll
    Module loaded: C:\WINDOWS\SYSTEM32\VCRUNTIME140D.dll
    Module loaded: C:\WINDOWS\SYSTEM32\ucrtbased.dll
    Module loaded: C:\WINDOWS\SYSTEM32\ucrtbased.dll
    NatVis script unloaded from 'C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers\atlmfc.natvis'
    NatVis script unloaded from 'C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers\concurrency.natvis'
    NatVis script unloaded from 'C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers\cpp_rest.natvis'
    NatVis script unloaded from 'C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers\stl.natvis'
    NatVis script unloaded from 'C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers\Windows.Data.Json.natvis'
    NatVis script unloaded from 'C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers\Windows.Devices.Geolocation.natvis'
    NatVis script unloaded from 'C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers\Windows.Devices.Sensors.natvis'
    NatVis script unloaded from 'C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers\Windows.Media.natvis'
    NatVis script unloaded from 'C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers\windows.natvis'
    NatVis script unloaded from 'C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers\winrt.natvis'
    eERROR: Process crashed
    dCDB PROCESS FINISHED, status 1, exit code -1073741515
    dNOTE: INFERIOR ILL
    dState changed from EngineSetupRequested(1) to InferiorShutdownRequested(13)
    dCALL: SHUTDOWN INFERIOR
    dINFERIOR FINISHED SHUT DOWN
    dState changed from InferiorShutdownRequested(13) to InferiorShutdownFinished(14)
    dState changed from InferiorShutdownFinished(14) to EngineShutdownRequested(15)
    dCALL: SHUTDOWN ENGINE
    dNOTE: ENGINE SHUTDOWN FINISHED
    dState changed from EngineShutdownRequested(15) to EngineShutdownFinished(16)
    Debugger finished.
    dState changed from EngineShutdownFinished(16) to DebuggerFinished(17)
    

  • Lifetime Qt Champion

    Hi @Flaviu-0,

    ~that is not the log I'm talking about. Please re-check.~

    Ok, you edited the post, that looks like the debugger log.

    Also, can you run the program?

    If not, you need to fix that first.

    Regards



  • @aha_1980

    When I ran the real app, I got:

    14:47:35: Starting D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\MyProject.exe ...
    14:47:35: The program has unexpectedly finished.
    14:47:35: The process was ended forcefully.
    14:47:35: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\MyProject.exe crashed.
    

    And the app didn't started.



  • Yes, I see that my program crashed, but how can I see where is the problem as long I cannot start the debugger ?


  • Lifetime Qt Champion

    @Flaviu-0

    crashes that early most often happen because of DLL incompatibilities.

    Tools like Dependency Walker help to debug such problems.

    Does this App use DLLs beside Qt?

    Regards



  • @aha_1980 said in The CDB process terminated:

    Dependency Walker

    Thank you for your replay. It mean a lot for me. I am trying to figure out where is the problem:

    98694acb-07c3-4e08-9f65-42903d63c80b-image.png

    Also, I got a direct message from Dependency Walker:

    Error: At least one required implicit or forwarded dependency was not found.
    Warning: At least one delay-load dependency module was not found.
    Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.
    

  • Lifetime Qt Champion

    @Flaviu-0 i think you can ignore the API-MS-* DLLs. Are these all DLLs that are needed in your screenshot?



  • Yes, GLU32.DLL, and QT5... all of them.

    6710259e-4093-4d85-b995-1a044ead8e4c-image.png


  • Lifetime Qt Champion

    @Flaviu-0 uhm, did you copy all of these DLLs to the build folder?

    at least the Qt DLLs don't need to be copied there if you want to run/debug the program from Creator. Creator sets up the PATH to the Qt installation directory for run.

    Not sure what happens if there is a version mismatch (i.e. correct DLL name, but wrong version, architecture, compiler...)



  • @Flaviu-0
    Where is VCRUNTIME140.DLL? Is that correctly installed somewhere, with any dependencies, and findable by PATH? Or MSVCP140.DLL? And the directory you show does not have the Qt5*.dll files shown required by Dependency Walker.

    I'm not saying they are not necessarily found --- DW might have shown something else if they had not been --- but they are not in the latest screenshot you have shown.

    Looking back, I don't that the EXE you ran DW on 2 screenshots ago is the right one for the other screenshot and for the Module loaded log stuff you showed earlier.



  • @JonB said in The CDB process terminated:

    VCRUNTIME140.DLL

    VCRUNTIME140.DLL is un level upper. Even if I copied into exe location, I have the same issue.



  • @Flaviu-0
    Where? There is no VCRUNTIME140.DLL in your screenshot.

    [Now you have just changed your post while I'm writing...]

    As I wrote yesterday, the Dependency Walker output you show is not for the executable for which you show the log and the screenshot of the DLLs in a folder.



  • @JonB In did, DW was from Release, not from Debug. Here, DW is from Debug MyProject.exe:

    aceb0d52-5ce1-4e92-bac6-6554e13e1c0b-image.png



  • I don't get it: if I run a Hello World example, I can do Debugging without any problem. Fine.

    My github project has compiled without errors, but with tons of warnings. Fine.

    When I try to do Debugging on my real app, I got that strange message from the post title.

    If I try to Run my project, I got:

    18:33:50: Starting D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\MyProject.exe ...
    18:33:50: The program has unexpectedly finished.
    18:33:50: The process was ended forcefully.
    18:33:50: D:\Project\MyProject\build-src-Desktop_Qt_5_12_10_MSVC2017_64bit-Debug\distrib\MyProject.exe crashed.
    

    Super strange !!!



  • I deleted the entire project, and I retrieve it again from github, I compiled again and now seem to go. I don't know what was the problem.


Log in to reply