Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Installing only the Qt Designer compatible with PyQt5.15.1 for MAC



  • Hi all,

    I'm new to Qt / PyQt5 actually I'm still learning so I'm seeking to install the Qt Designer compatible with PyQt 5.15 while I do want to focus on learning the concept then go to the bigger Qt Creator, meantime my system is quite an old MacBook Air Mid2011 and there is no enough space for the full package.

    I'd appreciate any help


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You can install only Qt Creator with the rest. Since you want to use it later on, I'd say start directly with it since it has the Designer functionality integrated.



  • Hi,
    unfortunately, my system is really old not to mention that I have really no enough desk space.


  • Lifetime Qt Champion

    I do not see the issue with the age of your MacBook Air. I have a MacBook Pro that is older that yours and it can still run Qt Creator even if locked out of the latest versions of macOS.

    As for your space issues, your should consider using an external hard drive to store your development stuff so you do not saturate your system disk.

    In the absolute, you could even install macOS on an external drive and boot on that one when developing so you have more space at hand.

    As for Qt Creator, I did not suggest to do a full Qt installation. Qt Creator can be installed standalone.


Log in to reply