Problem with QProcess on embedded system



  • i create a project that can run a exe file. i tried to run the program on linux(Ubuntu), and it works OK.
    when i run this on embedded it doesn't work.

    this is the code for the class that run the exe:

    @void ProcessControllerItem::startProcess(const QString& _path, const QString& _args)
    {
    QProcess* process = new QProcess;
    process->start(_path, _args.split(" "));
    }
    @

    when i run this function i pass the appropriate arguments to the function:

    1. the path - where the exe is (on the embedded - the path from the root)
    2. the arguments for the exe

    for example :
    @startProcess("/root/path/to/the/exe/myExeFile","1 2");@

    Does anyone have an idea why it does not work?

    tnx



  • I don't have any experience on embedded qt, but the first thing I would check is that the program exist and is executable, then that it is really not executed and maybe not executed and terminated immediately (wrong input?).



  • You should check the return value of QProcess' error() method.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.