Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt third parties libraries version query



  • Hi,
    I found the Qt 5.5.1 repository in github on this link https://github.com/qt/qt5/tree/5.5. It is mentioned in readme file the optional requirement of OpenSSL for SSL sockets or HTTPS and Wayland. Unfortunately, no information regarding the version.

    I would like to know also which version of below libraries are used in Qt 5.5.1.
    OpenSSL
    Wayland
    binutils
    bzip2
    cloog
    expat
    gcc
    gdb
    gmp
    libffi
    libiconv
    make
    mingw-libgnurx
    mingw-w64
    mpc
    mpfr
    ncurses
    ppl
    readline
    sqlite
    tcl
    tk
    winpthreads
    xz
    zlib
    aix-g++
    aix-g++-64
    aix-xlc
    aix-xlc-64
    android-g++
    blackberry-armle-v7-qcc
    blackberry-x86-qcc
    common
    cygwin-g++
    darwin-g++
    linux-archos-gen8-g++
    linux-arm-amlogic-8726M-g++
    linux-arm-hisilicon-hix5hd2-g++
    linux-arm-trident-pnx8473-g++
    linux-beagleboard-g++
    linux-imx53qsb-g++
    linux-imx6-g++
    linux-mipsel-broadcom-97425-g++
    linux-odroid-xu3-g++
    linux-rasp-pi-g++
    linux-rasp-pi2-g++
    linux-sh4-stmicro-ST7108-g++
    linux-sh4-stmicro-ST7540-g++
    linux-snowball-g++
    linux-tegra2-g++
    freebsd-g++
    freebsd-g++46
    freebsd-icc
    haiku-g++
    hpux-acc
    hpux-acc-64
    hpux-acc-o64
    hpux-g++
    hpux-g++-64
    hpuxi-acc-32
    hpuxi-acc-64
    hpuxi-g++-64
    hurd-g++
    irix-cc
    irix-cc-64
    irix-g++
    irix-g++-64
    linux-arm-gnueabi-g++
    linux-clang
    linux-clang-libc++
    linux-cxx
    linux-g++
    linux-g++-32
    linux-g++-64
    linux-icc
    linux-icc-32
    linux-icc-64
    linux-kcc
    linux-llvm
    linux-lsb-g++
    linux-pgcc
    lynxos-g++
    macx-clang
    macx-clang-32
    macx-g++
    macx-g++-32
    macx-g++40
    macx-g++42
    macx-icc
    macx-ios-clang
    macx-llvm
    macx-xcode
    netbsd-g++
    openbsd-g++
    qconfig.pri
    qdevice.pri
    qfeatures.pri
    qmodule.pri
    qnx-armle-v7-qcc
    qnx-x86-qcc
    sco-cc
    sco-g++
    solaris-cc
    solaris-cc-64
    solaris-cc-64-stlport
    solaris-cc-stlport
    solaris-g++
    solaris-g++-64
    tru64-cxx
    tru64-g++
    unixware-cc
    unixware-g++
    android-g++
    freebsd-clang
    linux-armcc
    linux-host-g++
    linux-scratchbox2-g++
    nacl-g++
    nacl64-g++
    qnx-X11-g++
    vxworks-ppc-dcc
    vxworks-ppc-g++
    vxworks-simpentium-dcc
    vxworks-simpentium-g++
    win32-g++
    win32-icc
    win32-msvc2005
    win32-msvc2008
    win32-msvc2010
    win32-msvc2012
    win32-msvc2013
    win32-msvc2015
    wince60standard-armv4i-msvc2005
    wince60standard-x86-msvc2005
    wince70embedded-armv4i-msvc2008
    wince70embedded-x86-msvc2008
    wince80colibri-armv7-msvc2012
    winphone-arm-msvc2013
    winphone-x86-msvc2013
    winrt-arm-msvc2013
    winrt-arm-msvc2015
    winrt-x64-msvc2013
    winrt-x64-msvc2015
    winrt-x86-msvc2013
    winrt-x86-msvc2015
    cc1
    cc1obj
    cc1objplus
    cc1plus
    collect2
    f951
    gnat1
    lto-wrapper
    lto1
    fixincl

    I will be glad to get a reply regarding my query.

    Regards,
    Manirul


  • Qt Champions 2019

    @m-manirul You really expect exact answer for each of these libs?!
    Why do you actually want to know that? For most of these libs many versions will work, so how can anybody give you an exact answer?
    Just try to build for your system.
    The only important part here is OpenSSL, I think for Qt 5.5 you need v1.0.x
    HTTPS is not a lib but encrypted HTTP.

    See also https://wiki.qt.io/Qt_5.5_Tools_and_Versions


Log in to reply