Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Eagle Pcb won’t start on Fedora Linux due to xcb and qt problem



  • Hello,
    I'm having trouble understanding console debug data while trying to get Eagle PCB layout software installed on my Dell laptop running Fedora 32 on an Intel 64 bit cpu. I do not have access to the build tree for Eagle and I know almost nothing about QT and xcb. Any suggestions will be much appreciated.

    Thanks,

    Jim

    I've included console debug output below in the hope that someone can help me better understand and fix the errors.

    [jcl@localhost eagle-9.6.2]$ setenv QT_DEBUG_PLUGINS 1 [jcl@localhost eagle-9.6.2]$ [jcl@localhost eagle-9.6.2]$ ./eagle QFactoryLoader::QFactoryLoader() checking directory path "/home/jcl/EE/Autodesk_EAGLE_9.6.2_English_Linux_64bit/eagle-9.6.2/plugins/platforms" ... QFactoryLoader::QFactoryLoader() looking at "/home/jcl/EE/Autodesk_EAGLE_9.6.2_English_Linux_64bit/eagle-9.6.2/plugins/platforms/libqxcb.so" Found metadata in lib /home/jcl/EE/Autodesk_EAGLE_9.6.2_English_Linux_64bit/eagle-9.6.2/plugins/platforms/libqxcb.so, metadata= { "IID": "org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3", "MetaData": { "Keys": [ "xcb" ] }, "className": "QXcbIntegrationPlugin", "debug": false, "version": 329988 }

    Got keys from plugin meta data ("xcb") QFactoryLoader::QFactoryLoader() checking directory path "/home/jcl/EE/Autodesk_EAGLE_9.6.2_English_Linux_64bit/eagle-9.6.2/platforms" ... qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in "" This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

    Available platform plugins are: xcb.

    Abort (core dumped) [jcl@localhost eagle-9.6.2]$ echo $QT_QPA_PLATFORM wayland [jcl@localhost eagle-9.6.2]$
    Here's some information showing contents of the eagle directory:

    [jcl@localhost eagle-9.6.2]$ ls
    bin cache doc eagle examples lib libexec ngspice plugins qt.conf README README.jcl resources translations
    [jcl@localhost eagle-9.6.2]$ tree plugins
    plugins
    ├── bearer
    │ ├── libqconnmanbearer.so
    │ ├── libqgenericbearer.so
    │ └── libqnmbearer.so
    ├── iconengines
    │ └── libqsvgicon.so
    ├── imageformats
    │ ├── libqgif.so
    │ ├── libqicns.so
    │ ├── libqico.so
    │ ├── libqjpeg.so
    │ ├── libqsvg.so
    │ ├── libqtga.so
    │ ├── libqtiff.so
    │ ├── libqwbmp.so
    │ └── libqwebp.so
    ├── platforms
    │ └── libqxcb.so
    ├── printsupport
    │ └── libcupsprintersupport.so
    └── xcbglintegrations
    ├── libqxcb-egl-integration.so
    └── libqxcb-glx-integration.so

    6 directories, 17 files



  • @SGaist said in Eagle Pcb won’t start on Fedora Linux due to xcb and qt problem:

    QT_QPA_PLATFORM

    Hello, and thanks again. I tried setting the environment variable "QT_QPA_PLATFORM" to xcb and the process core dumped. I also tried unsetting the variable and the process core dumped. However, after I renamed the file "qt.conf" to "qt.conf.save" the process runs. Thank you so much for helping me with this problem!

    Jim


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    How did you install eagle ?



  • I downloaded their most recent version (gz file) then installed it using “tar xvf tar.file”



  • @SGaist Thank you for the kind invite. In answer to your question, I downloaded the latest Eagle install file (gz file) then installed it using “tar xvf tar.file”


  • Lifetime Qt Champion

    So it looks like it's bundled with only the xcb backend while you seem to have wayland defined as QT_QPA_PLATFORM.

    Can you change that to xcb to see if it is starting properly ?
    Can you also try with that environment variable unset ?

    If still not, one other thing you can do is move the qt.conf file out of the folder so that it will try to use your distribution provided Qt.



  • @SGaist said in Eagle Pcb won’t start on Fedora Linux due to xcb and qt problem:

    QT_QPA_PLATFORM

    Hello, and thanks again. I tried setting the environment variable "QT_QPA_PLATFORM" to xcb and the process core dumped. I also tried unsetting the variable and the process core dumped. However, after I renamed the file "qt.conf" to "qt.conf.save" the process runs. Thank you so much for helping me with this problem!

    Jim


  • Lifetime Qt Champion

    Great !

    Since you have it working now, please mark the thread as solved using the "Topic Tools" button or the three doted menu beside the answer you deem correct so that other forum users may know a solution has been found :-)



  • Done, and thank you again! - Jim


Log in to reply