Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt 5.15 Depricated: QML Connections: Implicitly defined onFoo properties in Connections are deprecated.



  • Hello!

    If you get this message in QML log: "QML Connections: Implicitly defined onFoo properties in Connections are deprecated." Just change QML connection code:

    Connections {
    
    	target: oTarget;
    	onSignal: {
    		mYourFunction();
    	}
    }
    

    onto:

    Connections {
    
    	target: oTarget;
    	function onSignal () {
    		mYourFunction();
    	}
    }
    


  • Are all signals on objects going this route or just Connections objects?



  • I would like to know as well. Maybe the motivation was to allow for connections to overloaded signals?



  • Then it complains that functions are not allowed in QML. Nice. At least it works.



  • I cannot understand why the designer is generating unsupported code.
    I suppose that a gui should be first created using the designer and it should work.
    Manual qml changes should be reserved for advanced features only.


  • Lifetime Qt Champion

    @drwa Which designer? No designer was mentioned in this thread.



  • Hi folks,

    Brand new here, as a result of reaching this thread by searching "Implicitly defined onFoo properties in Connections are deprecated." I am running Archlinux with KDE. I ran sudo pacman -Syu a few days ago, and was no longer able to access the internet via wifi. With my multi-boot system, I am able to access wifi just fine in the same computer when running Kubuntu, so I know it's not a hardware issue. Because checking my journald.log gave me the following:

    7/2/20 2:30 PM plasmashell qrc:/plasma/plasmoids/org.kde.plasma.networkmanagement/contents/ui/PopupDialog.qml:126:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }

    I hope there may be some help available on this thread.

    I waited several days and just did another pacman update, hoping something would be fixed, but no. Also, there doesn't seem to be the general uproar on the archlinux.org forum that something like this normally generates, hence my looking elsewhere.

    I tried disabling NetworkManager.service and wpa_supplicant.service, then enabling and starting each separately without the other, then back to both, which I believe is what I had previous to this issue. No combination seems to work.

    I select one of my wifi SSID's, the Network Manager plasma app pauses for several seconds, then goes back to showing me the SSID choices available without connecting.

    The following sequence keeps cycling in journald.log:

    7/2/20 2:53 PM NetworkManager <info> [1593726812.7491] device (wlan0): set-hw-addr: set MAC address to 06:FD:BA:54:1F:C9 (scanning)
    7/2/20 2:53 PM NetworkManager <info> [1593726812.8231] device (wlan0): supplicant interface state: inactive -> disconnected
    7/2/20 2:53 PM NetworkManager <info> [1593726812.8231] device (p2p-dev-wlan0): supplicant management interface state: inactive -> disconnected
    7/2/20 2:53 PM NetworkManager <info> [1593726812.8287] device (wlan0): supplicant interface state: disconnected -> inactive
    7/2/20 2:53 PM NetworkManager <info> [1593726812.8288] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> inactive

    This despite the following:

    systemctl status wpa_supplicant.service
    ● wpa_supplicant.service - WPA supplicant
    Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; enabled; vendor preset: disabled)
    Active: active (running) since Thu 2020-07-02 14:20:20 MST; 25min ago
    Main PID: 392 (wpa_supplicant)
    Tasks: 1 (limit: 9370)
    Memory: 5.6M
    CGroup: /system.slice/wpa_supplicant.service
    └─392 /usr/bin/wpa_supplicant -u -s -O /run/wpa_supplicant

    Jul 02 14:20:20 archlinux-lenovo-g780 systemd[1]: Starting WPA supplicant...
    Jul 02 14:20:20 archlinux-lenovo-g780 wpa_supplicant[392]: Successfully initialized wpa_supplicant
    Jul 02 14:20:20 archlinux-lenovo-g780 systemd[1]: Started WPA supplicant.
    Jul 02 14:25:09 archlinux-lenovo-g780 wpa_supplicant[392]: wlan0: Reject scan trigger since one is already pending
    Jul 02 14:25:19 archlinux-lenovo-g780 wpa_supplicant[392]: wlan0: Reject scan trigger since one is already pending
    Jul 02 14:26:00 archlinux-lenovo-g780 wpa_supplicant[392]: wlan0: Reject scan trigger since one is already pending
    Jul 02 14:31:00 archlinux-lenovo-g780 wpa_supplicant[392]: wlan0: Reject scan trigger since one is already pending
    Jul 02 14:31:52 archlinux-lenovo-g780 wpa_supplicant[392]: wlan0: Reject scan trigger since one is already pending

    Hoping someone here can help!

    Thanks in advance,

    Bruce



  • @jsulm When using QtDesigner to add user input to items in a ui.qml file, the designer will autogenerate the deprecated connections code, as @drwa experienced. Changing this then promps a more urgent warning of fuctions not being supported in QuickUI, but the code will still run. Both connection methods show an error or warning, and is likely why @drwa and @ThirdStrand ended up on this forum page.



  • @Bruce1222 your problem is not related to the topic of this thread, please open a thread on the archlinux forum and ask there for help.

    The Message "QML Connections: Implicitly defined onFoo properties in Connections are deprecated. ..." is just a depreciation warning for developers, which has nothing todo with your network problem, unless the surrounding code can't handle this kind of warning.

    Kind regards,

    Jörn-Ingo Weigert



  • @nightshift

    Hi Jörn-Ingo,

    Thank you for responding. I will do that. As yet, there has been no notification of this problem at the archlinux forum. You're right. It's time to start a thread there.

    Stay healthy,

    Bruce


Log in to reply