Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt not working on fresh windows install



  • Hey!
    I worked with qt now for a while and hat to reinstall my Window.
    Then I installe Vs19 and qt. But when I now wanna debug my application it isnt working. With mingW is isnt entering my main() and just showing up my debug console with <Press any key to return>. With the Vs Debugger im getting that CDB terminated.

    I tried reinstall qt.
    Tried also installing different Version (Im now at the newest, Qt 5.15 I guess?).
    Repairing VS.

    When Im trying to execute my app from the debug folder im getting qt.qpa.plugin: Could not find the Qt platform plugin "windows" in "". Here I also moved the qwindows.dll in the directory of the executable.

    What am I lacking in my installation?
    When someone need more information from me, just say it and I will post it :)

    Hopefully someone can help me :)
    Greetings Maxim.


  • Qt Champions 2019

    @FleeXo What do you actually want to use: MinGW or VS19?



  • @jsulm I prefer to use the VS Debugger. I also just recognised that new projects are working just fine.
    My project is also still working on my linux notebook.


  • Qt Champions 2019

    @FleeXo Then did you install Qt for Microsoft compiler and did you install CDB (it is not part of Visual Studio)?



  • @jsulm CDB got installed for me with the Windows SDK. Well it gets auto completed atleast and also exists there. And I have installed QT for Microsoft Compiler :(

    EDIT:
    That are the logs when I try to debug.

    wNote: This log contains possibly confidential information about your machine, environment variables, in-memory data of the processes you are debugging, and more. It is never transferred over the internet by Qt Creator, and only stored to disk if you manually use the respective option from the context menu, or through mechanisms that are not under the control of Qt Creator's Debugger plugin, for instance in swap files, or other plugins you might use.
    wYou may be asked to share the contents of this log when reporting bugs related to debugger operation. In this case, make sure your submission does not contain data you do not want to or you are not allowed to share.
    w
    dStart parameters: 'CidetIDE' mode: 1
    dABI: x86-windows-msvc2019-pe-64bit
    dLanguages: c++ 
    dExecutable: D:\QT\build-CidetIDE-Desktop_Qt_5_14_2_MSVC2017_64bit-Debug\debug\CidetIDE.exe  [terminal]
    dDirectory: D:\QT\build-CidetIDE-Desktop_Qt_5_14_2_MSVC2017_64bit-Debug
    dDebugger: C:\Program Files\Windows Kits\10\Debuggers\x64\cdb.exe
    dProject: D:\QT\qt_IDE
    dAdditional Search Directories:
    dSysroot: 
    dDebug Source Location: 
    dDebugger settings:
    dAdditionalArguments:   (default: )
    dAdjustBreakpointLocations: true  (default: true)
    dAllPluginBreakpoints: true  (default: true)
    dAlwaysAdjustColumnWidths: true  (default: true)
    dAutoDerefPointers: true  (default: true)
    dAutoEnrichParameters: true  (default: true)
    dAutoQuit: false  (default: false)
    dBreakEvent:   (default: )
    dBreakOnAbort: false  (default: false)
    dBreakOnCatch: false  (default: false)
    dBreakOnCrtDbgReport: false  (default: false)
    dBreakOnFatal: false  (default: false)
    dBreakOnThrow: false  (default: false)
    dBreakOnWarning: false  (default: false)
    dBreakpointCorrection: true  (default: true)
    dBreakpointsFullPath: false  (default: false)
    dCDB_Console: true  (default: false)  ***
    dCloseBuffersOnExit: false  (default: false)
    dCloseMemoryBuffersOnExit: true  (default: true)
    dDisplayStringLimit: 100  (default: 100)
    dEnableReverseDebugging: false  (default: false)
    dExtraDumperFile:   (default: )
    dFirstChanceExceptionTaskEntry: true  (default: true)
    dFontSizeFollowsEditor: false  (default: false)
    dGdbCustomDumperCommands:   (default: )
    dGdbPostAttachCommands:   (default: )
    dGdbStartupCommands:   (default: )
    dIgnoreFirstChanceAccessViolation: false  (default: false)
    dIntelFlavor: false  (default: false)
    dLoadGdbDumpers2: false  (default: false)
    dLoadGdbInit: true  (default: true)
    dLogTimeStamps: false  (default: false)
    dMaximalStackDepth: 20  (default: 20)
    dMaximalStringLength: 10000  (default: 10000)
    dMultiInferior: false  (default: false)
    dNoPluginBreakpoints: false  (default: false)
    dQmlInspector.ShowAppOnTop: false  (default: false)
    dRaiseOnInterrupt: true  (default: true)
    dRegisterForPostMortem: false  (default: false)
    dSecondChanceExceptionTaskEntry: true  (default: true)
    dSelectedPluginBreakpoints: false  (default: false)
    dSelectedPluginBreakpointsPattern: .*  (default: .*)
    dShowQObjectNames2: true  (default: true)
    dShowQmlObjectTree: true  (default: true)
    dShowQtNamespace: true  (default: true)
    dShowStandardNamespace: true  (default: true)
    dShowThreadNames: false  (default: false)
    dSkipKnownFrames: false  (default: false)
    dSortStructMembers: true  (default: true)
    dSourcePaths:   (default: )
    dStationaryEditorWhileStepping: false  (default: false)
    dSwitchModeOnExit: false  (default: false)
    dSymbolPaths:   (default: )
    dTargetAsync: false  (default: false)
    dUseAlternatingRowColours: false  (default: false)
    dUseCodeModel: true  (default: true)
    dUseDebuggingHelper: true  (default: true)
    dUseDynamicType: true  (default: true)
    dUseMessageBoxForSignals: true  (default: true)
    dUsePythonDumper: true  (default: true)
    dUseToolTips: true  (default: true)
    dUseToolTipsInBreakpointsView: false  (default: false)
    dUseToolTipsInLocalsView: false  (default: false)
    dUseToolTipsInStackView: true  (default: true)
    dWarnOnReleaseBuilds: true  (default: true)
    dWatchdogTimeout: 20  (default: 20)
    dState changed from DebuggerNotReady(0) to EngineSetupRequested(1)
    dCALL: SETUP ENGINE
     Attaching to 10848...
     Launching C:\Program Files\Windows Kits\10\Debuggers\x64\cdb.exe -aqtcreatorcdbext.dll -lines -G -c ".idle_cmd !qtcreatorcdbext.idle" -y ""\^"""\^""" -p 10848 -pr -pb
     using E:\IDEs\qt\Tools\QtCreator\lib\qtcreatorcdbext64\qtcreatorcdbext.dll of 5/19/2020 3:45 AM.
     C:\Program Files\Windows Kits\10\Debuggers\x64\cdb.exe running as 7916
     Microsoft (R) Windows Debugger Version 10.0.17763.132 AMD64
     Using CDB based breakpoint correction.
     Copyright (c) Microsoft Corporation. All rights reserved.
     *** wait with pending attach
     Error: Change all symbol paths attempts to access '""' failed: 0x7b - The filename, directory name, or volume label syntax is incorrect.
     ************* Path validation summary **************
     Response                         Time (ms)     Location
     Error                                          ""
     Symbol search path is: ""
     Executable search path is: 
     Module loaded: CidetIDE.exe
     Module loaded: ntdll.dll
     Module loaded: C:\Windows\System32\KERNEL32.DLL
     Module loaded: C:\Windows\System32\KERNELBASE.dll
     Module loaded: E:\IDEs\qt\5.14.2\msvc2017_64\bin\Qt5Widgetsd.dll
     Module loaded: E:\IDEs\qt\5.14.2\msvc2017_64\bin\Qt5Cored.dll
     Module loaded: E:\IDEs\qt\5.14.2\msvc2017_64\bin\Qt5Guid.dll
     Module loaded: C:\Windows\System32\WS2_32.dll
     Module loaded: C:\Windows\System32\GDI32.dll
     Module loaded: C:\Windows\System32\SHELL32.dll
     Module loaded: C:\Windows\System32\win32u.dll
     Module loaded: C:\Windows\System32\RPCRT4.dll
     Module loaded: C:\Windows\System32\ucrtbase.dll
     Module loaded: C:\Windows\System32\gdi32full.dll
     Module loaded: C:\Windows\System32\ADVAPI32.dll
     Module loaded: C:\Windows\System32\cfgmgr32.dll
     Module loaded: C:\Windows\System32\msvcp_win.dll
     Module loaded: C:\Windows\System32\msvcrt.dll
     Module loaded: C:\Windows\System32\shcore.dll
     Module loaded: C:\Windows\System32\USER32.dll
     Module loaded: C:\Windows\System32\sechost.dll
     Module loaded: C:\Windows\System32\combase.dll
     Module loaded: C:\Windows\System32\ole32.dll
     Module loaded: C:\Windows\System32\bcryptPrimitives.dll
     Module loaded: C:\Windows\System32\windows.storage.dll
     Module loaded: C:\Windows\System32\profapi.dll
     Module loaded: C:\Windows\System32\powrprof.dll
     Module loaded: C:\Windows\System32\UMPDC.dll
     Module loaded: C:\Windows\System32\shlwapi.dll
     Module loaded: C:\Windows\System32\kernel.appcore.dll
     Module loaded: C:\Windows\System32\cryptsp.dll
     NatVis script unloaded from 'C:\Program Files\Windows Kits\10\Debuggers\x64\Visualizers\atlmfc.natvis'
     NatVis script unloaded from 'C:\Program Files\Windows Kits\10\Debuggers\x64\Visualizers\concurrency.natvis'
     NatVis script unloaded from 'C:\Program Files\Windows Kits\10\Debuggers\x64\Visualizers\cpp_rest.natvis'
     NatVis script unloaded from 'C:\Program Files\Windows Kits\10\Debuggers\x64\Visualizers\stl.natvis'
     NatVis script unloaded from 'C:\Program Files\Windows Kits\10\Debuggers\x64\Visualizers\Windows.Data.Json.natvis'
     NatVis script unloaded from 'C:\Program Files\Windows Kits\10\Debuggers\x64\Visualizers\Windows.Devices.Geolocation.natvis'
     NatVis script unloaded from 'C:\Program Files\Windows Kits\10\Debuggers\x64\Visualizers\Windows.Devices.Sensors.natvis'
     NatVis script unloaded from 'C:\Program Files\Windows Kits\10\Debuggers\x64\Visualizers\Windows.Media.natvis'
     NatVis script unloaded from 'C:\Program Files\Windows Kits\10\Debuggers\x64\Visualizers\windows.natvis'
     NatVis script unloaded from 'C:\Program Files\Windows Kits\10\Debuggers\x64\Visualizers\winrt.natvis'
    eERROR: Process crashed
    dCDB PROCESS FINISHED, status 1, exit code -1073741515
    dNOTE: INFERIOR ILL
    dState changed from EngineSetupRequested(1) to InferiorShutdownRequested(13)
    dCALL: SHUTDOWN INFERIOR
    dINFERIOR FINISHED SHUT DOWN
    dState changed from InferiorShutdownRequested(13) to InferiorShutdownFinished(14)
    dState changed from InferiorShutdownFinished(14) to EngineShutdownRequested(15)
    dCALL: SHUTDOWN ENGINE
    dNOTE: ENGINE SHUTDOWN FINISHED
    dState changed from EngineShutdownRequested(15) to EngineShutdownFinished(16)
     Debugger finished.
    dState changed from EngineShutdownFinished(16) to DebuggerFinished(17)
    

Log in to reply