Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt SDK && old symbian devices



  • Hi all,
    I'm trying to develop an application for my E66 phone .
    I read "here":http://labs.qt.nokia.com/2011/11/08/qt-4-7-4-release-bundle-for-symbian-news/ that my symbian version is not supported by SDK 1.1.4 and I need to use 1.1.2 version.

    Now I'm downloading SDK 1.1.2 but what about 1.1.3 ? I've installed it (1.1.3) and with it I can build a .sis file to install in my phone. I only can't run in debug mode in the device becouse I get an error message about "CODA".

    Can someone explain me better the differences between SDK 1.1.2 and 1.1.3 referred to old symbian?



  • bq. This 1.1.2 release contained still the Application TRK debugging tool support that is the best solution for these earlier devices. There is also build targets available. Later SDKs have only CODA debugging functionality that works only on later Symbian releases.

    According to the "doc":http://labs.qt.nokia.com/2011/11/08/qt-4-7-4-release-bundle-for-symbian-news/.

    So, may be you should use TRK, instead of CODA



  • Thanks Rahul but my question is on the difference between 1.1.2 and 1.1.3 referred to old symbian devices.
    SDK 1.1.3 contains the TRK debugging tool bu it seems I cen't use it because QtCreator ask me about "CODA"...



  • oh!! Its not asking for trk even after changing projects-> Device agent -> trk !? Thats strange :(
    No much idea on the differences :(



  • [quote author="Rahul Das" date="1321891760"]oh!! Its not asking for trk even after changing projects-> Device agent -> trk !? Thats strange :( [/quote]

    I didn't know about "Device agent -> trk" where should I find it?



  • i have it in the the project tab of the creator. :)



  • [quote author="Rahul Das" date="1321895777"]i have it in the the project tab of the creator. :)[/quote]

    What SDK / QtCreator version are you using?



  • Creator is 2.2.1 , and SDk : 1.1.2



  • [quote author="Rahul Das" date="1321896418"]Creator is 2.2.1 , and SDk : 1.1.2[/quote]

    Ok, thanks again. I'll install the SDK 1.1.2 and I'll try... :)



  • You're welcome :) n All the best..



  • I confirm... The "device agent" selection is available in the SDK 1.1.2 but it isn't in 1.1.3 .

    I'm confused about the availability on the TRK sis file in the SDK 1.1.3 while it isn't used by QtCreator...



  • So, 1.1.3/4 doesn't support TRK but old symbians don't connect with out TRK!
    So, practically ,there is no way to do on device debugging with 1.1.3/4 SDK!! ??

    Have you tried installing CODA on your device ?



  • For the tests I made it seems it's not possible to use TRK with 1.1.3/4 but with 1.1.3 I can build the app and install manually on my device.

    I tried to install CODA on my E66 but I get a message about "incompatibility".



  • Documentation is clear. :( I skipped this part from reading :(
    Have to use sdk 1.1.2.

    bq. S60 3rd Edition devices support only Qt 4.6.3, not Qt 4.7 or later. Further, support for the App TRK on-device debugging agent has been removed from Qt Creator 2.3. Only CODA is supported from Qt SDK 1.1.3 onward, and CODA does not support S60 3rd Edition. Therefore, you can no longer run and debug applications from Qt Creator on S60 3rd Edition devices.

    bq. The tool chains for developing applications using Qt 4.6.3 for Symbian and Qt 4.7.3 for Symbian^ 3 and Symbian Anna have been removed from Qt SDK 1.1.4. To develop such applications, download and use Qt SDK version 1.1.2 instead. It contains Qt 4.6.3 for Symbian and Qt 4.7.4 for Symbian support for Symbian devices with the Application TRK debug agent.



  • I'm not sure about this:

    bq. S60 3rd Edition devices support only Qt 4.6.3, not Qt 4.7 or later.

    because I successfully installed Qt 4.7.3 on my S60 3rd Edition device...



  • Anyway, you have to use 1.1.2 SDK for 3rd edition. (and shouldn't update ,as long as you work with 3rd edition!!!!)



  • Here again!
    How can I select 4.6.3 when building for old Symbian (S60 3rd) with SDK 1.1.2 ?

    It actually allow me only to select 4.7.3 ...




Log in to reply