Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QT 5.12.7 GCC enthält Konfigurationsprobleme



  • Hi,

    habe mir den QT Creator mit dem Online Installer installiert und habe dabei nur das Paket GCC 64Bit ausgewählt. Habe dann in der Uni eine Aufgabe bekommen, in der wir ein Projekt per git klonen sollten, etwas daran ändern, einen Test hinzufügen und dann über build & run ausführen sollen.

    Mein Problem ist: Immer wenn ich meine C++ Klasse in einen externen Header schreibe und dann über #include "xyz/xyz.h" in meinen Test einbinde, bekomme ich zwar gesagt das die Methoden und die Tests alle verlinkt werden, sobald ich aber auch Build gehe bekomme ich folgnden Fehler:

    22:10:21: Der Prozess "make" -j4 konnte nicht gestartet werden
    Fehler beim Erstellen/Deployment des Projekts todomat (Kit: Desktop Qt 5.12.7 GCC 64bit)
    Das Kit Desktop Qt 5.12.7 GCC 64bit enthält Konfigurationsprobleme, die die Ursache für dieses Problem sein könnten.
    Bei der Ausführung von Schritt "Make"
    

    Der vorherige Fehler:

    21:49:20: Der Prozess "make" -f '/home/luca/Dokumente/Uni/Software Qualität/Praktikum_3/20s-projects-todomat/build-todomat-Desktop_Qt_5_12_7_GCC_64bit-Debug/Makefile' qmake_all konnte nicht gestartet werden
    
    Fehler beim Erstellen/Deployment des Projekts todomat (Kit: Desktop Qt 5.12.7 GCC 64bit)
    
    Das Kit Desktop Qt 5.12.7 GCC 64bit enthält Konfigurationsprobleme, die die Ursache für dieses Problem sein könnten.
    
    Bei der Ausführung von Schritt "qmake"
    

    Habe in meinen Einstellungen nachgeguckt, dort waren für C++ der GCC und der CLang eingestellt, habe den CLang rausgenommen, bekomme aber immer noch einen Konfigurationsfehler...

    Bei Kits sind bei mir für C und C++ der GCC eingestellt, habe aber trotzdem noch das gelbe Warndreieck vorne dran. Da ich zum ersten mal mit QT und makefiles arbeite, kenne ich mich leider nicht so gut damit aus...

    System ist Manjaro 19.2 auf Gnome, vor kurzem erst Frisch installiert.

    Hoffe mir kann jemand helfen,

    MfG.

    (Ich weiß nicht wie ich die Bilder in einem Spoiler verstecken kann)

    QT_3.png
    Das hier habe ich erst Bilder machen entdeckt, könnte hier der Fehler liegen?
    QT_2.png QT_1.png


  • Lifetime Qt Champion

    @marcopasta said in QT 5.12.7 GCC enthält Konfigurationsprobleme:

    habe aber trotzdem noch das gelbe Warndreieck vorne dran

    Was sagt dir dieses Warndreieck wenn du den Cursor drüber positionierst?
    Außerdem wäre es hilfreich wenn du unter Kits das Kit auswählen und den Inhalt zeigen würdest.


  • Lifetime Qt Champion

    @marcopasta said in QT 5.12.7 GCC enthält Konfigurationsprobleme:

    /home/luca/Dokumente/Uni/Software Qualität/Praktikum_3/

    Ein Schuss in's Blaue, aber Pfade mit Leerzeichen und Sonderzeichen (Umlaute!) sind immer wieder ein Quell der Freude.

    Vermeide diese wenn möglich. Ansonsten wie @jsulm sagte, prüfe mal die Details im Kit.

    Grüße


  • Lifetime Qt Champion

    @marcopasta

    Achso, und ist denn der make-Befehl überhaupt installiert? Was passiert wenn Du make im Terminal eingibst?

    Bei Debian/Ubuntu ist sudo apt install build-essential die Grundinstallation für SW-Entwicklung.



  • @jsulm said in QT 5.12.7 GCC enthält Konfigurationsprobleme:

    @marcopasta said in QT 5.12.7 GCC enthält Konfigurationsprobleme:

    habe aber trotzdem noch das gelbe Warndreieck vorne dran

    Was sagt dir dieses Warndreieck wenn du den Cursor drüber positionierst?
    Außerdem wäre es hilfreich wenn du unter Kits das Kit auswählen und den Inhalt zeigen würdest.

    Hi, Warndreieck sagt "Debugger not Setup"

    @aha_1980 said in QT 5.12.7 GCC enthält Konfigurationsprobleme:

    @marcopasta said in QT 5.12.7 GCC enthält Konfigurationsprobleme:

    /home/luca/Dokumente/Uni/Software Qualität/Praktikum_3/

    Ein Schuss in's Blaue, aber Pfade mit Leerzeichen und Sonderzeichen (Umlaute!) sind immer wieder ein Quell der Freude.

    Vermeide diese wenn möglich. Ansonsten wie @jsulm sagte, prüfe mal die Details im Kit.

    Grüße

    Tatsächlich war das ein Problem, hab das geändert, hab in den Projekteinstellungen die Build-Pfade von Release, Debug und Profile geändert und danach hat es funktioniert. Hatte auch gar nicht gemerkt, dass make gar nicht installiert war. Danke für die Hilfe!


  • Lifetime Qt Champion

    Hi @marcopasta,

    schön das es jetzt geht. Dann schließe bitte diesen Thread als SOLVED (mit TOPIC TOOLS unter deinem ersten Beitrag).

    Danke!


Log in to reply