Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

error while adding catkin package



  • I'm trying to develope a desktop application using qt quick and catking for a ros based robot controller which will be cross plateform latter. My problem is when i add this line:

    find_package(catking REQUIRED)
    

    inside the cmakelists.txt file it shows error inside the qt ide:

    /home/dinesh/ros_controller/CMakeLists.txt:28: error: By not providing "Findcatkin.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "catkin", but CMake did not find one. Could not find a package configuration file provided by "catkin" with any of the following names: catkinConfig.cmake catkin-config.cmake Add the installation prefix of "catkin" to CMAKE_PREFIX_PATH or set "catkin_DIR" to a directory containing one of the above files.  If "catkin" provides a separate development package or SDK, be sure it has been installed.
    

    But when i run the build command from the terminal it shows no error: i.e when i run the command

    cmake --build . --target all
    

    it succesfully builds without any error.
    Here what i have done till now is added the catking in find package command inside the cmakelistst.txt file.
    added extra package.xml file outside the build directory of the qt project so that ros packages i.e catking can be used. and the app also runs from the terminal as i checked.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Where is the findcatkin.cmake script located ?



  • This post is deleted!

Log in to reply