Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Updated Qt Creator today to version 4.11.2



  • I haven't changed anything in the project that I was building in the previous version, now in the Compiler Output:

        12:25:48: Running steps for project XMLMPAM...
        12:25:48: Starting: "/usr/bin/make" clean -j8
        make: *** No rule to make target `XMLMPAM'.  Stop.
        The platform SDK has been changed from version 10.15 to version 10.15.4.
        /Users/simonplatten/Qt/5.12.3/clang_64/mkspecs/features/mac/sdk.mk:22: *** ^.  Stop.
        This requires a fresh build. Please wipe the build directory completely,
        including any .qmake.stash and .qmake.cache files generated by qmake.
        12:25:48: The process "/usr/bin/make" exited with code 2.
        12:25:48: Starting: "/Users/simonplatten/Qt/5.12.3/clang_64/bin/qmake" /Users/simonplatten/XMLMPAM/XMLMPAM.pro -spec macx-clang CONFIG+=debug CONFIG+=x86_64 CONFIG+=qml_debug
        12:25:48: The process "/Users/simonplatten/Qt/5.12.3/clang_64/bin/qmake" exited normally.
        12:25:48: Starting: "/usr/bin/make" -f /Users/simonplatten/build-XMLMPAM-Qt_64bit-Debug/Makefile qmake_all
        make: *** No rule to make target `XMLMPAM'.  Stop.
        The platform SDK has been changed from version 10.15 to version 10.15.4.
        This requires a fresh build. Please wipe the build directory completely,
        including any .qmake.stash and .qmake.cache files generated by qmake.
        /Users/simonplatten/Qt/5.12.3/clang_64/mkspecs/features/mac/sdk.mk:22: *** ^.  Stop.
        12:25:48: The process "/usr/bin/make" exited with code 2.
        Error while building/deploying project XMLMPAM (kit: Desktop Qt 5.12.3 clang 64bit5)
        When executing step "qmake"
        12:25:49: Elapsed time: 00:01.
    

    I haven't seen this before and in the Issues:

        :-1: error: No rule to make target `XMLMPAM'.  Stop.


  • Found it...after a search on google I found someone else who had the same problem and all I can say it that it must have been caused as a result of a change to the build and "pro" make file system. Until today my files and build have worked.

    All I had to do was have a file of the same name as the project, so I renamed main.cpp to XMLMPAM.cpp and it built fine and no more error message.

    mmm....Maybe I spoke to soon, whilst having a source file of the same name as the "pro" file gets rid of the message, the project won't build:

        16:50:25: Running steps for project XMLMPAM...
        16:50:25: Starting: "/Users/simonplatten/Qt/5.14.2/clang_64/bin/qmake" /Users/simonplatten/XMLMPAM/XMLMPAM.pro -spec macx-clang CONFIG+=debug CONFIG+=x86_64 CONFIG+=qml_debug
        16:50:26: The process "/Users/simonplatten/Qt/5.14.2/clang_64/bin/qmake" exited normally.
        16:50:26: Starting: "/usr/bin/make" -f /Users/simonplatten/build-XMLMPAM-Desktop_Qt_5_14_2_clang_64bit-Debug/Makefile qmake_all
        The platform SDK has been changed from version 10.15 to version 10.15.4.
        This requires a fresh build. Please wipe the build directory completely,
        including any .qmake.stash and .qmake.cache files generated by qmake.
        /Users/simonplatten/Qt/5.14.2/clang_64/mkspecs/features/mac/sdk.mk:22: *** ^.  Stop.
        16:50:26: The process "/usr/bin/make" exited with code 2.
        Error while building/deploying project XMLMPAM (kit: Desktop Qt 5.14.2 clang 64bit)
        When executing step "qmake"
        16:50:26: Elapsed time: 00:01.
    

    Xcode version is 11.4 (11E146)

    After another google found this and executed in terminal:

        sudo find / -name '.qmake.*' -delete
    

    A lot of found files could not be deleted but at the end of it, I tried building again and it worked.


  • Moderators

    @SPlatten delete your shadow build folder, really delete it cleanwill not be enough, and build it from scratch.



  • What exactly is the Shadow build folder? I've just emptied the build folder and executed QMake I get the same message.


  • Moderators

    @SPlatten
    you find the absolute path in the build settings of QtCreator

    719e5122-fcc5-40f0-ac6b-5f89a8a2508e-image.png



  • Yes, that contains the location of all the object files and executable that I just removed, it was an empty folder. Then executing QMake resulted in the same error, didn't get as far as building.

    As an additional step, I exited Qt Creator, make sure the folder was empty, then relaunched Qt Creator.

    Still the same message.


  • Moderators

    @SPlatten
    including any .qmake.stash and .qmake.cache files ?

    as an additional move, you can try:
    Closing QtCreator

    • delete the *.pro.user file
      -Open the project anew

    This should force a new project setup and could help.



  • This time I deleted the folder, then re-created it, same message after running QMake.

    Then I closed Qt Creator, deleted the pro.user file, restarted Qt Creator, run QMake, guess what? Same message.



  • After loosing several hours of messing around with this, what can I do so I can start working again, I've deleted the build folder many times, I've restarted Qt Creator many times.

    I'm going around and around in circles:

    No rule to make target 'XMLMPAM'. Stop.


  • Moderators

    @SPlatten what happens when you create a new fresh hello world project?



  • Just create a new project and lots of new issues, before I even got to compile:

        13:52:44: Running steps for project HelloWorld...
        13:52:44: Starting: "/Users/simonplatten/Qt/5.11.2/clang_64/bin/qmake" /Users/simonplatten/HelloWorld/HelloWorld.pro -spec macx-clang CONFIG+=debug CONFIG+=x86_64 CONFIG+=qml_debug
        Project WARNING: Qt has only been tested with version 10.13 of the platform SDK, you're using 10.15.
        Project WARNING: This is an unsupported configuration. You may experience build issues, and by using
        Project WARNING: the 10.15 SDK you are opting in to new features that Qt has not been prepared for.
        Project WARNING: Please downgrade the SDK you use to build your app to version 10.13, or configure
        Project WARNING: with CONFIG+=sdk_no_version_check when running qmake to silence this warning.
        13:52:45: The process "/Users/simonplatten/Qt/5.11.2/clang_64/bin/qmake" exited normally.
        13:52:45: Starting: "/usr/bin/make" -f /Users/simonplatten/build-HelloWorld-Desktop_Qt_5_11_2_clang_64bit-Debug/Makefile qmake_all
        /Users/simonplatten/Qt/5.11.2/clang_64/mkspecs/features/mac/sdk.mk:11: *** ^.  Stop.
        The platform SDK has been changed from version 10.15 to version 10.15.4.
        This requires a fresh build. Please wipe the build directory completely,
        including any .qmake.stash and .qmake.cache files generated by qmake.
        13:52:45: The process "/usr/bin/make" exited with code 2.
        Error while building/deploying project HelloWorld (kit: Desktop Qt 5.11.2 clang 64bit)
        When executing step "qmake"
        13:52:45: Elapsed time: 00:00.

  • Moderators

    @SPlatten
    well, maybe someone else can help,

    For me, deleting the bild directory always fixed the platform SDK has been changed issues for me.

    That said, just to make sure, you did update Xcode after the MacOs update ?
    And 5.11 is really old. I would at least suggest 5.12, that one gets as an LTS version potential bugfixes



  • I'm now at the stage where I've completely uninstalled everything, now about to try download and install again.



  • After a long wait to install the new version, I get exactly the same message, omg!!!

    Any suggestions ?

        15:01:31: Running steps for project XMLMPAM...
        15:01:31: Starting: "/Users/simonplatten/Qt/5.14.2/clang_64/bin/qmake" /Users/simonplatten/XMLMPAM/XMLMPAM.pro -spec macx-clang CONFIG+=debug CONFIG+=x86_64 CONFIG+=qml_debug
        15:01:33: The process "/Users/simonplatten/Qt/5.14.2/clang_64/bin/qmake" exited normally.
        15:01:33: Starting: "/usr/bin/make" -f /Users/simonplatten/build-XMLMPAM-Desktop_Qt_5_14_2_clang_64bit-Debug/Makefile qmake_all
        make: *** No rule to make target `XMLMPAM'.  Stop.
        The platform SDK has been changed from version 10.15 to version 10.15.4.
        This requires a fresh build. Please wipe the build directory completely,
        including any .qmake.stash and .qmake.cache files generated by qmake.
        /Users/simonplatten/Qt/5.14.2/clang_64/mkspecs/features/mac/sdk.mk:22: *** ^.  Stop.
        15:01:33: The process "/usr/bin/make" exited with code 2.
        Error while building/deploying project XMLMPAM (kit: Desktop Qt 5.14.2 clang 64bit)
        When executing step "qmake"
        15:01:33: Elapsed time: 00:02.


  • This is what I've tried now:

    1. Delete build folder completely.
    2. Delete XMLMPAM.pro.user.
    3. Launch Qt Creator.
    4. Go to Projects.
    5. Check only Desktop Qt 5.14.2 clang 64bit.
    6. Click on the Configure Project button.
    7. When back to Projects, right clicked on Build directory and selected Create Folder.
    8. From the Build menu selected Run qmake.

    In the Issues tap up pops:

        No rule to make target `XMLMPAM'. Stop.
    

    Can someone please help?

    This is the content of my pro file, which hasn't changed:

        #-------------------------------------------------
        #
        # Project created by QtCreator 2018-10-15T09:17:31
        #
        #-------------------------------------------------
        
        QT       += core gui sql widgets qml
        
        TARGET = XMLMPAM
        TEMPLATE = app
        
        # The following define makes your compiler emit warnings if you use
        # any feature of Qt which has been marked as deprecated (the exact warnings
        # depend on your compiler). Please consult the documentation of the
        # deprecated API in order to know how to port your code away from it.
        DEFINES += QT_DEPRECATED_WARNINGS
        
        # Uncomment to include XML debug information
        #DEFINES += DEBUG_XML
        #DEFINES += DEBUG_SIGNALS
        DEFINES += DEBUG_THREADS
        
        # You can also make your code fail to compile if you use deprecated APIs.
        # In order to do so, uncomment the following line.
        # You can also select to disable deprecated APIs only up to a certain version of Qt.
        #DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0x060000    # disables all the APIs deprecated before Qt 6.0.0
        
        CONFIG += c++11
        CONFIG += sdk_no_version_check
        
        SOURCES += \
                clsFileThread.cpp \
                clsJSON.cpp \
                clsMainWnd.cpp \
                clsQtPushBtn.cpp \
                clsSignal.cpp \
                clsScriptHelper.cpp \
                clsSocketThread.cpp \
                clsThread.cpp \
                main.cpp
        
        HEADERS += \
                clsJSON.h \
                clsMainWnd.h \
                clsFileThread.h \
                clsCtrlBase.h \
                clsQtPushBtn.h \
                clsScriptHelper.h \
                clsSignal.h \
                clsSocketThread.h \
                clsThread.h
        
        FORMS += \
                clsMainWnd.ui
        
        # Default rules for deployment.
        qnx: target.path = /tmp/$${TARGET}/bin
        else: unix:!android: target.path = /opt/$${TARGET}/bin
        !isEmpty(target.path): INSTALLS += target
        
        RESOURCES += \
            clsmainwnd.qrc


  • Found it...after a search on google I found someone else who had the same problem and all I can say it that it must have been caused as a result of a change to the build and "pro" make file system. Until today my files and build have worked.

    All I had to do was have a file of the same name as the project, so I renamed main.cpp to XMLMPAM.cpp and it built fine and no more error message.

    mmm....Maybe I spoke to soon, whilst having a source file of the same name as the "pro" file gets rid of the message, the project won't build:

        16:50:25: Running steps for project XMLMPAM...
        16:50:25: Starting: "/Users/simonplatten/Qt/5.14.2/clang_64/bin/qmake" /Users/simonplatten/XMLMPAM/XMLMPAM.pro -spec macx-clang CONFIG+=debug CONFIG+=x86_64 CONFIG+=qml_debug
        16:50:26: The process "/Users/simonplatten/Qt/5.14.2/clang_64/bin/qmake" exited normally.
        16:50:26: Starting: "/usr/bin/make" -f /Users/simonplatten/build-XMLMPAM-Desktop_Qt_5_14_2_clang_64bit-Debug/Makefile qmake_all
        The platform SDK has been changed from version 10.15 to version 10.15.4.
        This requires a fresh build. Please wipe the build directory completely,
        including any .qmake.stash and .qmake.cache files generated by qmake.
        /Users/simonplatten/Qt/5.14.2/clang_64/mkspecs/features/mac/sdk.mk:22: *** ^.  Stop.
        16:50:26: The process "/usr/bin/make" exited with code 2.
        Error while building/deploying project XMLMPAM (kit: Desktop Qt 5.14.2 clang 64bit)
        When executing step "qmake"
        16:50:26: Elapsed time: 00:01.
    

    Xcode version is 11.4 (11E146)

    After another google found this and executed in terminal:

        sudo find / -name '.qmake.*' -delete
    

    A lot of found files could not be deleted but at the end of it, I tried building again and it worked.


  • Moderators

    @SPlatten
    Great you managed to solve the issue and thanks for sharing the answer!

    So it was a qmake.cache issue, but your compiler somehow picktup those files outside the normal search directory 🤔 Do you happen to use a versioning system? IIRC there was an issue with git ignore and qmake.cache 🤷‍♂️



  • I use git.



  • I have run into this 3 times before. As far as I know it's within Qt. When Mac OS/Xcode update, there are some targets within Qt itself that "break" because they point to specific versions of something on the Mac side. Each time it has happened I've had to wait for a new minor version at least of Qt for it to resolve.
    https://doc.qt.io/qt-5/macos.html
    They must be using Mac OS or Xcode minor versions within Qt. WHY they still do this I do not understand! Why not just go Major versions? If Xcode goes from 11.3 to 11.4 or Mac OS from 10.15.3 to 10.15.4 (I got both those updates recently so I don't know which, but last time it was Xcode) why should I have to wait to compile our app? That seems like a huge deal to me.
    So last time this happened, the community just told me don't allow Xcode to upgrade or keep an old copy around. I guess they don't understand the current world of Apple where they basically force everything on us.
    Did you find a way around it? I tried 15.4.2 and still go the error so likely now I have to wait for 15.14.3.


Log in to reply