Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Android - Missing SDK Tools & Platform



  • Hey guys,

    I have been developing an app on my work PC for Android using Qt Creator. It works perfectly on this PC. However, when trying to configure the development environment for my personal PC, I get the following errors.

    b58f3fc0-92c2-4696-ac0b-515f781a8973-image.png

    I am using the exact same versions of the JDK and NDK on both computers. I have also tried much earlier (and latest) versions of the development kits to no avail, as well as 32/64 bit versions and running with elevated permissions. As for the Android side; I am using Android Studio with the in-built SDK manager with the following configuration.

    5f4d2e00-c3b8-4685-bff4-2085975929e2-image.png

    13d2e595-1499-45e7-8b7c-395c16c3d5bf-image.png

    As you can see, the platform tools are installed, it's just that Qt cannot read them.

    Qt Creator 4.11.1 - MSVC 2017 32 bit on Windows 10 64-bit.

    Any help would be appreciated!

    Thanks,
    Ryan



  • Solved! If anyone else is having this issue:

    Open up Android Studio > Configure > SDK Manager > SDK Tools.

    Untick "Hide ObsoletePackages", tick Android SDK Tools (Obsolete) and apply.

    Restart Qt Creator and link against the SDK tools again.

    990565ee-d48b-440e-b16c-6404833b4322-image.png


Log in to reply