Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Ctrl-Click not working



  • Hello,

    I have the Qt creator 4.11.0 and ctrl-click shortcut doesn't always work. I have to click a lot of times on a function name to take me to the function definition. Any ideas why?

    Thanks,
    Roberto



  • @RobertoC
    Just checked and it works OK for me (Linux, Creator 4.8.1). I don't know the answer, but I suppose the first thing to ask is: once you hold Ctrl key down, if you move mouse over the function you want to click on does it show the underline to indicate clickable or not when it is not going to work? Does it make any difference to your behaviour if when you hold Ctrl the mouse pointer is already over the function name versus if you move the mouse from outside the function name onto the function name?



  • It doesn't make any difference if the mouse pointer is already over the function or is outside the functions. Also, every time I hold down the Ctrl the function name, or parameters which can be accessed are underlined.


  • Moderators

    @RobertoC its a matter of project size, I'm afraid.

    will always work in small projects. You can turn of the clang code model (if it's still possible in 4.11) that should help



  • The project size is not big. Also, cland code model is disabled.

    Everything worked fine on 4.8.1, but since updating to 4.11.0 it's not working. I also tried reinstalling the old version but now it happens also on that one.

    Thanks


  • Lifetime Qt Champion

    @RobertoC
    Is pressing F2 on the symbol also slow ?



  • @mrjj F2 works perfectly.



  • I have the same exact issue. And F2 works perfectly with me as well.
    I'd report a bug. But I don't know what information to include.

    I'm on macos so it's cmd+click for me.


Log in to reply