Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

New qt library for older qt version



  • Dear all,

    I hope somebody is able to assist me with the following. I have an embedded screen which runs qt5.6. I want to use this embedded screen in an industrial application.

    The library that I want to use is only supported from qt5.11. (QtOpcua). Is there a way arround this? How can I use this library for this screen?

    Is it somehow possible to update the qtversion without rebuilding the image running on the screen? (Manufacturer is unable to update it)

    Hope somebody is able to help me,
    Thanks in advance,
    TMJJ


  • Moderators

    You can try compiling QtOpcua module using your Qt 5.6 toolkit and toolchain. If that works, then you should be able to deploy it to your device and use it in your project. If it does not work, then find a different board ;-) Or perhaps use linuxdeployqt to create a self-contained package that will shich Qt together with it. I have no idea if this will work on an embedded device - it's definitely not a standard use of this tool.


Log in to reply