Very weird error while building in Symbian SDK for LINUX! please help!



  • Good evening,

    I have been programming in QT (desktop applications) a lot in linux without any problems.
    But now i'm trying to make applications for Symbian using linux, with the Symbian SDK for Linux.
    http://developer.qt.nokia.com/forums/viewthread/6101
    I've connected my nokia succesfully with the QT SDK using CODA, and my scource code doesn't have any errors.
    But when I build it i get the following error in the SBSv2 build log:
    @A critical tool, '/bin/bash', did not return the required version '.GNU bash, version [34].':
    GNU bash, versie 4.1.7(2)-release (i686-pc-linux-gnu)
    Copyright (C) 2009 Free Software Foundation, Inc.
    De licentie is GPLv3+: GNU GPL versie 3 of later.
    Please check that '/bin/bash' is in the path.@

    Can somebody help me out with this please?

    Thanks in advance!


  • Moderators

    Not strange at all: The bash version string does not match the expected string due to you using a non-english locale. Try adding LC_ALL=C to your build environment.

    Note that Symbian SDK for Linux is not officially supported: There are still lots of small quirks like this.



  • Thanks, changing the build environment did solve my problem!
    And Symbian SDK works stable now, so i can't complain.. i look forward to see it implemented in the QT SDK for Linux.

    Regards,

    Tristan


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.