Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt-based programs fail to start in 5120x1440


  • Banned

    This post is deleted!

  • Lifetime Qt Champion

    [EDIT: Original post deleted. It was spam, copied + pasted from https://www.reddit.com/r/Qt5/comments/csmzom/qtbased_programs_fail_to_start_in_5120x1440/ --JKSH]

    @RonWesley Did you try to ask Manjaro/i3 community?
    Also it would be interesting to know whether a simple "Hello World" Qt GUI app shows this behaviour, but that would require additional work on your side.



  • I can confirm the same behavior on Linux Mint 19 for the backintime backup tool and the openshot video editor. It first hangs for a couple of minutes at the last line of this log:

    qt5ct: using qt5ct plugin
             app:INFO ------------------------------------------------
             app:INFO             Fri Mar 12 00:00:29 2021            
             app:INFO               Starting new session              
             app:INFO ------------------------------------------------
             app:INFO          OpenShot (version 2.5.1-dev2)          
             app:INFO ------------------------------------------------
             app:INFO openshot-qt version: 2.5.1-dev2
             app:INFO libopenshot version: 0.2.5-dev2
             app:INFO platform: Linux-4.15.0-135-generic-x86_64-with-LinuxMint-19-tara
             app:INFO processor: x86_64
             app:INFO machine: x86_64
             app:INFO python version: 3.6.9
             app:INFO qt5 version: 5.9.5
             app:INFO pyqt5 version: 5.10.1
        language:INFO Qt Detected Languages: ['en-US', 'en']
        language:INFO LANG Environment Variable: en_US.UTF-8
        language:INFO LOCALE Environment Variable: 
        language:INFO OpenShot Preference Language: Default
    project_data:INFO Setting default profile to HDV 720 24p
             app:INFO Setting font to /usr/lib/python3/dist-packages/openshot_qt/images/fonts/Ubuntu-R.ttf
    logger_libopenshot:INFO Connecting to libopenshot with debug port: 5556
             app:INFO Setting custom dark theme
    qt5ct: D-Bus global menu: no
    
    

    Then tries to proceed with rendering and opens an empty window that spans probably 3x the width of my 5120px monitor. Please, someone look into this. I can provide further logs, if needed. Switching to 3840x1080 for every QT app is not an option.



  • This is odd, my desktop res is 5120 × 2880 and works well under debian, windows and macOS.



  • Not sure if it matters, but I also have a Samsung one, as does RonWesley.
    https://www.amazon.de/-/en/gp/product/B07PQ4MPT6
    And everything works fine in 3840x1080.



  • @jsulm could you provide such a Hello World application to test with my OS (Linux Mint 19, based on Ubuntu bionic)? Or point at any other simple QT application that you expect to work?


  • Lifetime Qt Champion

    @afedulov Simply create a default widget application in QtCreator (there is wizard for that)...



  • @artwaw @jsulm this issue is still unsolved, the bug report for it was auto-closed without resolution: https://bugreports.qt.io/browse/QTBUG-77828
    Could you maybe think of some workaround? Are there any standard QT parameters like default resolution that could be passed upon application startup? I also have a second display, so maybe forcing the application to start on a smaller-resolution screen could help? Everything works fine as soon as I change the resolution of the 49" Samsung monitor to 3840x1440 instead of the native 5120x1440.



  • @afedulov Have you tried the simple widgets app like @jsulm asked you in March?


  • Lifetime Qt Champion

    The issue was auto solved because there has been no feedback to the request for tests.

    If you can do what was suggested there and add some more information to it then the bug can be reopen.


Log in to reply