Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Android app immediately dies



  • Hi guys, I'm having a problem while running my app on my android device (Android 9)

    When I run the app, a white screen is showed, the things that I programmed are not displayed..

    When I run with Qt, from the Application Output there is

    12-22 07:24:02.477   644   646 V vold    :
    12-22 07:24:05.079   644   646 V vold    :
    12-22 07:24:05.489   644   646 V vold    :
    12-22 12:38:44.866 20048 20048 F DEBUG   :
    12-22 12:39:11.537 20535 20535 F DEBUG   :
    12-22 12:39:13.952 20574 20574 F DEBUG   :
    
    
    "com.phoenixsoftware.ash" died.
    

    The app immediately dies!
    What should I do? (I can give you more details if you ask)

    I am not using Ministro



  • Sometimes there are some weird errors:

    F linker  : CANNOT LINK EXECUTABLE "/system/bin/dpmd": "/system/lib64/libdpmframework.so" is 32-bit instead of 64-bit
    
    E Qt: Can't create main activity
    
    E Qt: android.content.res.Resources$NotFoundException: String array resource ID #0x0
    ...
    


  • Hi there. Are you using Qt5.14 ? I've recently did a fresh install and upgraded to 5.14 and now two of my apps are completly broken with the white screen that you mencioned. I don´t now what the problem is but I serioulsy thinking about downgrading when I have the time.



  • @Angelo13C @johngod did you guys find a solution? Im having the exact same issue..



  • I'm not sure if this is the case, but I've had similar issues in Android when the bin folder has a very long name.


Log in to reply