RPI 0 W Issues when QT GUI before starting network



  • Hello,

    I am new on raspberry, QT and linux. I have built my own image for Raspberry Pi Zero W using Buildroot.

    I am using busybox as init system.

    I have and HDMI display attached to the rpi.

    The aim:

    • Running a gui app at startup (it should start at maximum 2-3 seconds after power on the rpi). For that reason I have considered of using QT over linuxFB or EGLFS (as first approach I am using linuxfb because is simpler to enable it on buildroot).

    • Have Wifi and SSH enabled.

    • Because of loading the brcmfmac driver to enable wifi chipset of the rpi takes a lot of time (modprobe brcmfmac), I need to run the qt app
      before enabling wifi and ssh.

    WHAT I HAVE:

    • I can enable wifi and ssh when booting rpi using inittab and rcS scripts.

    • I can run qt samples over linuxFB (analogclock) using inittab and rcS scripts.

    ISSUE:

    If I run the qt app (is running over fb0) before loading wifi drivers, starting network, etc, the system seems to not keep executing the next rcS scripts (enable wifi driver, starting network, starting ssh...).

    Also, I am not able to kill the qt app (ctrl+c), or at least the app does not dissapears from the display.

    I am shure there are many things I have missing or doing incorrectly, but I have no idea how to fix it.

    Thanks in advance,

    Rafa



  • You have to run your qt-app in the background, otherwise your init script waits for it to end.

    Try starting it like this in your init script: "nohup YOURQTAPPLICATION > /tmp/qtapp.log &" or use start-stop-daemon.



  • @rickp Thanks, that is what I was looking for.

    At inittab I use:

    ::sysinit:nohup MYAPP &
    

    before the rcS script and it works perfectly



  • @rscr Hello, I need exactly the same things. But my Qt application doesn't start on linuxfb in inittab. What is your buildroot configuration. Did you do anything else to start the application on startup?


Log in to reply