QtCreator Permission Denied to File

  • Hi! I have a fresh installation of Qt and im using it to program a Grayhill 3d70 touchscreen. Until now i followed Grayhill's guide, and everything went OK, except that in the 3rd of 5 step of the Deployment QtCreator pops a message saying:

    01:12:02: File transfer failed: Permission denied (C:/Users/MY_USERNAME/AppData/Local/Temp/QtCreator.WksHZu).
    01:12:02: Deploy step failed.
    Error while building/deploying project ghQmlDemo (kit: Qt-5.12.2-3Dxx)
    When executing step "Upload files via SFTP"

    I tried to change app permissions and to run it as administrator, but no luck... Any help is greatly appreciated!

  • Lifetime Qt Champion

    @rafaelellin said in QtCreator Permission Denied to File:


    Is it possible that this file already exists and is open?

  • @jsulm I dont think so. It is a file created by Qt itself amd im not really sure about its use(i can't find it in the folder it says it is,probably it is created for a short amount of time?). The point is, that the permission thing happens and in different circumstances: when i tried to configure SSH connectivity, I found the openssh .exe files inside Windows/System32/OpenSSH I copied and pasted the exact file paths in Qt Settings, and it says the files and folders do not exist. Also, when I try to browse the System32 directory from within the Qt Settings, I can see seemingly all directories except OpenSSH(but it is clearly there, I checked many times).
    As a fix, I tried to copy the ssh .exe files on a new folder I created on my desktop, and boom, it worked fine.
    Thats the reason I suspect it has to do with application permissions. I might be wrong, but for now its my best guess and I cant solve it.

  • Lifetime Qt Champion

    Hi @rafaelellin,

    which Creator version is that?

    There has been some issues with deployment on Windows recently, the last I remember was https://bugreports.qt.io/browse/QTCREATORBUG-23269

    It seems your issue is related, so you might want to comment on that bugreport.


  • This post is deleted!

  • Hi @aha_1980!
    The version of the QtCreator is 4.10.2 as seen in the picture below. The bug report is about a problem a bit different than mine. It seems that their problem is that the Creator uses the same default(wrong) path every time despite told not to. My problem is that it cannot access the existing folder (I fixed this when I created a copy of the folder in my Desktop. Qt can now find the folder and use the files). I can later upload photos of the exact error messages if it helps.

  • Lifetime Qt Champion

    Hi @rafaelellin,

    in that case you should create a new bugreport and provide the information you already gave here.

    Please post a link to the bug afterwards, so we can follow. Thanks!

  • @aha_1980
    Hi again!
    I created a bug report at https://bugreports.qt.io/browse/QTCREATORBUG-23295, lets hope that someone finds a fix. Thanks for your time!