Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

configure -prefix



  • When I click command:

    configure -prefix c:\newlib\qt5 -debug-and-release -mp -opensource -confirm-license -nomake examples -nomake tests -skip qtwebengine -platform win32-msvc2017

    unknown option skip

    why?


  • Lifetime Qt Champion

    Hi,

    What version of Qt ?
    On what version of Windows ?
    Where are you calling configure from ?

    One thing you can do if you don't want to build a module is to move its folder outside the sources you want to use to build.



  • @SGaist qt 4.8.6 windows 10, calling in call "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\Build\vcvarsall.bat" x86

    One thing you can do if you don't want to build a module is to move its folder outside the sources you want to use to build. // I dont understand this, where take folder and which folder?


  • Lifetime Qt Champion

    There's an issue here, you give a prefix which contains "qt5" in its name and now you write that you are building Qt 4.8.6. So which version are you building ? The -skip option is valid only for Qt 5 and the QtWebEngine module is not available in Qt 4.

    Note also that Qt 4's latest release is 4.8.7 but at the same time it has reached end of life a long time ago.

    So what is you current exact situation ?

    @Cinexus123 said in configure -prefix:

    One thing you can do if you don't want to build a module is to move its folder outside the sources you want to use to build. // I dont understand this, where take folder and which folder?

    As written, the folder of the module you do not want to build. As for where, that's up to you, just outside the Qt sources you want to build.



  • Ok I understand, I take version 5.13.2 but in this version I cant see configure file? Where is he?


  • Lifetime Qt Champion

    @Cinexus123 said in configure -prefix:

    Where is he?

    In the Qt source code. Did you install Qt source code?



  • @jsulm Sorry but I am begginer in this topic. I cant see difference between qt, qtcreator and qt source code. I install version from qt.io 5.13.2 and next i should copy https://github.com/qt/qtbase to qt folder this?


  • Lifetime Qt Champion

    First thing: why do you want to build Qt ?

    As for the source code, if you have a precise version in mind, you can use the MaintenanceTool to download the version you want.

    Otherwise, get the code from https://code.qt.io



  • @SGaist I must do that because I must to do a project to school and I have this in manual. It must be in 100%. I dont understand one thing because when I install version 5.13.2 I cant see configure file, I clone repo: https://github.com/qt/qtbase and made operation on this:

    cd c:\newlib\qt\5.13.2
    call "c:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Auxiliary\Build\vcvarsall.bat" x86
    configure -prefix c:\newlib\qt5 -debug-and-release -mp -opensource -confirm-license -nomake examples -nomake tests -skip qtwebengine -platform win32-msvc2017
    set CL=/MP
    jom
    jom install


  • Lifetime Qt Champion

    What must be 100% ?



  • manual which I paste in last post


  • Lifetime Qt Champion

    My question is what is the point of building Qt for your project ?
    Is there any feature not available in the pre-built version that you need to enable ?



  • @SGaist It is difficult to say because i must do a job which i get for my friend and he gives me a manual and i repeat a step. When I give you manual on priv can you help me how to do this step by step because i made it 8 hours and i have bugs.


  • Lifetime Qt Champion

    Like I already wrote, I don't see the use of building Qt yourself if the ore-built version provides what you need.

    In any case, simplify your life and download the sources from the MaintenanceTool.



  • Ehhh maybe I am moron but I dont understand. I download MaintanaceTool and qt version 5.13.2 but this file doesnt have configure file. I must configure and building, I dont know why but I must. I must use activeperl and jom. When i clone jom to qtbase file i get this bug(qmake -r):

    Reading C:/newlib/qtbase/jom/jom/src/app/app.pro
    Reading C:/newlib/qtbase/jom/jom/src/jomlib/jomlib.pro
    Project MESSAGE: Can't locate path to MSYS. This is needed for flex.
    Reading C:/newlib/qtbase/jom/jom/tests/tests.pro

    And nmake command:

    NMAKE: fatal error U1073: unknown how to create "C: \ newlib \ qtbase \ lib \ Qt6Guid.lib"
    Stop.


  • Lifetime Qt Champion

    You have to download the sources, that's a separate option to select in the maintenance tool.

    Did you follow the the Qt for Windows - Building from Source guide ?

    On a side note, your clone is on the dev branch which is for Qt 6. Select the correct branch before configuring anything.


Log in to reply