Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

you don't seem to have 'make' or 'qmake' in your PATH



  • @jsulm yes I tried with this -xcb,the result is

    xcb.png

    xcb1.png ..



  • Hi..

    I am getting like above screenshots,

    xcb is enabled,but xkbcommon and libs.xcb is failed....and EGL on X11 .....no

    how to proceed next...


  • Lifetime Qt Champion

    @Asha Please check the configure log or add -v parameter to your configure call and see what exactly happens when configures checks for xcb. You probably do not have needed header files and libs in your sysroot.



  • @jsulm Ok..

    please go through the config.log

    configlog.png

    configlog1.png .....

    If I want to use Linuxfb backend,than how to use it because this is enabled..


  • Lifetime Qt Champion

    @Asha said in you don't seem to have 'make' or 'qmake' in your PATH:

    If I want to use Linuxfb backend

    I don't think you can use it as long as X11 is running, so first you need to stop it.
    Then start your executable with "-platform linuxfb" parameter.
    See https://doc.qt.io/qt-5/embedded-linux.html



  • @jsulm Ok..

    Any idea about config.log file...


  • Lifetime Qt Champion

    @Asha said in you don't seem to have 'make' or 'qmake' in your PATH:

    Any idea about config.log file...

    Well, it just tells you that some things will not be built, but as long as you don't need them you can ignore that.



  • @jsulm If i ignore this things,then what is the problem,why I am getting could not find the qt platform plugin "eglfs" in "".....

    How to see which backend is running on my device?...



  • The error is:

    qt.qpa.plugin: could not find the Qt platform plugin "eglfs" in ""
    This application failed to start because no Qt platform plugin could be initialized.Reinstalling the application may fix this problem..

    Available platform plugins are: linuxfb,minimal,offscreen,vnc.

    Remote process crashed..

    "no Qt platform plugin could be initialized"
    how to initialize Qt platform plugin

    Reinstalling the application may fix this problem..
    not getting what to reinstall,and how?


  • Lifetime Qt Champion

    @Asha said in you don't seem to have 'make' or 'qmake' in your PATH:

    How to see which backend is running on my device?

    You should know what device you have and what is running on it. You can ask the vendor.

    "If i ignore this things,then what is the problem,why I am getting could not find the qt platform plugin "eglfs" in ""....." - these errors are NOT related to eglfs.

    If eglfs is disabled by configure then enable eglfs when calling configure and check the configure log and see what errors are there related to eglfs. You're probably missing header files and/or libraries in your sysroot.



  • @jsulm

    You're probably missing header files and/or libraries in your sysroot(which headers and libraries are required please let me know)

    while deploying the kit,for sysroot
    I am specifing the path:

    /home/beagle/BBB/sysroot

    in this sysroot i have again four directories
    home lib usr sbin

    which one i need to select for sysroot.

    or I need to give the path below

    /home/beagle/BBB/sysroot/home/debian/Qt5ForBBB1


  • Lifetime Qt Champion

    @Asha said in you don't seem to have 'make' or 'qmake' in your PATH:

    which one i need to select for sysroot.

    It is not about specifying the sysroot, you're already doing this.
    The actual question is: does your sysroot contain everything needed?
    I already suggested to check the configure log file to see whether there are any errors when configure tests for eglfs functionality...



  • @jsulm
    I checked configure log file,the issues with eglfs shown below attachement, please go through this

    egl.png

    egl1.png

    egl2.png

    please let me know ,if any error is there..


  • Lifetime Qt Champion

    @Asha As you can see EGL libraries were not found. I guess you're missing them in your sysroot.



  • This post is deleted!


  • @jsulm Good Morning

    while giving this command,
    arm-linux-gnueabihf-readlf -d libQt5Gui.so

    The result is:

    Dynamic section at offset 0x3920e8 contains 37 entries:
    Tag Type Name/Value
    0x00000001 (NEEDED) Shared library: [libQt5Core.so.5]
    0x00000001 (NEEDED) Shared library: [libpthread.so.0]
    0x00000001 (NEEDED) Shared library: [librt.so.1]
    0x00000001 (NEEDED) Shared library: [libdl.so.2]
    0x00000001 (NEEDED) Shared library: [libstdc++.so.6]
    0x00000001 (NEEDED) Shared library: [libm.so.6]
    0x00000001 (NEEDED) Shared library: [libgcc_s.so.1]
    0x00000001 (NEEDED) Shared library: [libc.so.6]
    0x0000000e (SONAME) Library soname: [libQt5Gui.so.5]
    0x0000001d (RUNPATH) Library runpath: [$ORIGIN]
    0x0000000c (INIT) 0x8b48c
    0x0000000d (FINI) 0x34a304
    0x00000019 (INIT_ARRAY) 0x39b158
    0x0000001b (INIT_ARRAYSZ) 44 (bytes)
    0x0000001a (FINI_ARRAY) 0x39b184
    0x0000001c (FINI_ARRAYSZ) 4 (bytes)
    0x00000004 (HASH) 0xf8
    0x00000005 (STRTAB) 0x28610
    0x00000006 (SYMTAB) 0x9b80
    0x0000000a (STRSZ) 308470 (bytes)
    0x0000000b (SYMENT) 16 (bytes)
    0x00000003 (PLTGOT) 0x3a2230
    0x00000002 (PLTRELSZ) 31160 (bytes)
    0x00000014 (PLTREL) REL
    0x00000017 (JMPREL) 0x83ad4
    0x00000011 (REL) 0x77bb4
    0x00000012 (RELSZ) 48928 (bytes)
    0x00000013 (RELENT) 8 (bytes)
    0x6ffffffc (VERDEF) 0x77858
    0x6ffffffd (VERDEFNUM) 17
    0x0000001e (FLAGS) ORIGIN
    0x6ffffffb (FLAGS_1) Flags: ORIGIN
    0x6ffffffe (VERNEED) 0x77aa4
    0x6fffffff (VERNEEDNUM) 6
    0x6ffffff0 (VERSYM) 0x73b06
    0x6ffffffa (RELCOUNT) 2428

    So,how to overcome by this missing LibEGL.so library....



  • Hi,

    I have The below libraries in this path /usr/lib/x86_64-linux-gnu

    libEgl.so
    libEGL.so.1
    libEGL.so.1.1.0
    libEGL_mesa.so.0



  • Hi,

    How to use this patchelf for solving this issue,

    Any suggestions...



  • can i use symlink to solve this issue..

    sudo ln -s /usr/lib/x86_64-linux-gnu/libEGL.so /home/beagle/Qt5ForBBB1/lib



  • @jsulm Hi,

    In my .pro file ,i included

    tarhet.path = $$[Qt5ForBBB1]/bin
    INSTALLS += target

    After this ,I run the application

    know getting the error,

    rsync error:some files/attrs were not transferred(see previous errors)(code 23) at main.c(1207) [sender=3.1.3]
    rsync failed with exit code 23.
    Deploy step failed.
    Error while building/deploying project bbb(kit : BBB)
    when executing step "deploy files via rsync"

    what it means,

    I am trying to synchronize with this command

    rsync -avz debian@192.168.7.2:/usr sysroot

    now also getting same some files and attrs were not transferred...



  • @jsulm sorry,but I want to know what exactly that x11..

    because i understood x11 is for windowing system..(shall i ask more about x11 which you talking)

    but i am using the

    operating system: debian(linux)
    beagleboneboard
    Qtcreator(building to support beagleboneboard)...


Log in to reply