Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

qWidget missing or vignetted?



  • Hello,
    I have a project that has a mainwindow with a qTabWidget in the toolbar.
    This works fine and I have tested it on Linux and Widows.
    However now I have been running the software on a different machine (WIndows 7) and there the tabs at the top of the qTabWidget do not show up in the gui. Only the widget content of the selected tab is visible.

    What could be the reason for this?


  • Lifetime Qt Champion

    Hi,

    On what version of Windows is this happening ?
    What makes that machine different from the others ?



  • I don't really know what the crucial difference between the machines could be. There is nothing special about it.
    The screen size on that machine is a bit smaller (its a notebook), but the GUI still fits in there without a problem.
    Its happening on one Windows 10 machine (however with Win10 or Win7 on any other machine I've tried it works without problems).


  • Lifetime Qt Champion

    Then check if there's anything different version wise, hardware wise, driver version.



  • I have copied all the Qt.dlls from the machine where it worked. So everything in there is exactly the same. The only thing i could think of is that maybe there is another version of the Visual Studio redistributables installed. Could that make any difference?


  • Lifetime Qt Champion

    Unlikely, by the way, what are you showing on that widget that keeps hiding itself ?



  • The widget that is hiding is the QTabBar of a QTabWidget.
    There is also a cornerWidget set to the QTabWidget which consists of a Widget with a few QToolButtons on it, which is also not displayed.

    So the whole area above the content of the QTabWidget is not shown. However the content itself is visible.


  • Qt Champions 2019

    What Qt version do you use? I'm asking because of this issue here: https://forum.qt.io/topic/107032/issue-after-update-from-5-9-to-5-12-qdialogs-qwidgets-not-updating-after-show which you maybe also hit.



  • The Qt version is 5.12.0
    I have not noticed the bug with show() mentioned in the other post.
    I'll try to update the version anyhow because this seems like it could be something similar. Thanks for the hint.



  • The update of the version to 5.13.0 did not help.

    However I found out, that not the widget is missing, but the whole content of the GUI is a bit scaled so it gets vignetted at the borders of the GUI on top/bottom as well as a bit left/right.
    In the Qt conf I have set

    [Platforms]
    WindowsArguments = dpiawareness=0
    

    so the GUI shows correctly, when high DPI-monitors are used.
    Could that cause the problem?

    It seems to also be a bit more distorted in vertical direction, than in horizontal.


Log in to reply