Over and Over SQL Driver not loaded.. 1year with same problem..



  • Re: [SOLVED] QSqlDatabase: QMYSQL driver not loaded with QMYSQL driver available in OSX Mavericks

    Hi All,

    One year ago I somehow was influenced to use QT instead of Java, in order to create a SW that runs into any OS.
    Since the argument was to avoid Java, I did not even blink :)

    So I started doing na app to consult a DB remote, and 1 year ago, I had HUGE troubles because the driver was not loading.
    I do this after hours at night only, so I remember I took almost 3 weeks until I make it work..was a real nightmare. I was so happy that it works that I did not documented...

    Problem.. 1 year later, by accident I installed a new version of QT, updated my Labtop to a new MACos version, and puff... the annoying "Driver Not loaded" and is two weeks already passed...and me stuck in the most stupid thing on earth...

    So, I follow all the theories seen in google and forums, and nothing .. can you help? what i did:

    I follow the Topic on this forum and repeated the procedure, about checking otool, using "install_name_tool"..but nothing..

    in the end I re-installed the Mysql drivers and did all steps as written here:
    http://zrsite.com/detail.php?id=138

    and nothing..

    My (and from 36'500 Developers as we can see in forum) Standard error:
    QSqlDatabase: QMYSQL driver not loaded
    QSqlDatabase: available drivers: QSQLITE QMYSQL QMYSQL3 QODBC QODBC3 QPSQL QPSQL7
    "Driver not loaded Driver not loaded"

    My lib file:

    Marios-MacBook-Pro-2:sqldrivers marioalmeida$ otool -L libqsqlmysql.dylib
    libqsqlmysql.dylib:
    libqsqlmysql.dylib (compatibility version 0.0.0, current version 0.0.0)
    @rpath/QtSql.framework/Versions/5/QtSql (compatibility version 5.10.0, current version 5.10.0)
    @rpath/QtCore.framework/Versions/5/QtCore (compatibility version 5.10.0, current version 5.10.0)
    /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration (compatibility version 1.0.0, current version 1.0.0)
    /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit (compatibility version 1.0.0, current version 275.0.0)
    @executable_path/../Frameworks/libmysqlclient.20.dylib (compatibility version 20.0.0, current version 20.0.0)
    /usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 307.5.0)
    /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1238.50.2)


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What version of the MySQL libraries do you have ?
    Where exactly are they stored on your machine ?


Log in to reply