Multiple build for a versions



  • Please let me know which version will work with Qt Creator. And is any extra configurations?

    qt-everywhere-opensource-src-4.8.6.zip
    qt-opensource-windows-x86-mingw482-4.8.6-1.exe
    qt-opensource-windows-x86-vs2008-4.8.6.exe
    qt-opensource-windows-x86-vs2010-4.8.6.exe

    • Can I install multiple versions.
    • Will these two VS integrate and work with new VS during installation.

  • Lifetime Qt Champion

    Hi,

    1. This the source package, you have to built it in order to use it
    2. MinGW build
    3. Visual Studio 2008 build
    4. Visual Studio 2010 build

    You can use 1 after you built it, and 3 to 4 directly in Qt Creator provided that you installed the corresponding compilers.

    Yes, you can have multiple versions of Qt in parallel no problem with that.
    No, they will not. Up to VS2015, there's no compatibility between Visual Studio versions. VS2017 is the first one that is backward compatible with VS2015.

    Also note that, if your really need to work with Qt 4, you should at least go with Qt 4.8.7 which is the latest and last version of the 4 series. Even more important, Qt 4 has reached end of life a long time ago, you should rather start with Qt 5.


 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.