Planned maintenance has been done but it did not solve the problem. So work will continue on this and a new time for trying updates will be announced asap.

QML Rendering Issues on iMX7



  • Hello,

    I'm getting strange rendering issues when I switch to the Material theme when demoing the Quick Controls 2 "gallery" app. Background colors are disappearing and "tap animations" are being rendered in the top left of the screen instead of over the control as expected. The default theme is fine, though.

    I've uploaded pictures showing the background colors missing. Link to videos showing strange tap animations is below.

    EDIT: I uploaded a screenshot of the tap animation issue. See red circled area in the upper left corner. That animation should be over the middle tab at the bottom of the screen. Anyone have any ideas?

    https://bit.ly/2YLmkUx (OneDrive Share)

    Can anyone point me in the right direction to get this resolved?

    Here are some details about my environment:

    • Hardware: Variscite VAR-SOM-MX7 iMX7 processor
    • Yocto build: thud (full version thud-fslc-4.14.78-mx7-v1.0)
    • Using linuxfb

    Thanks for any help you can provide.

    0_1565295591095_Capture.JPG

    1_1565191099062_Material Theme Bad 2.jpg 0_1565191099062_Material Theme Bad 1.jpg



  • Hum...am I alone on this one?

    I can't reproduce this on the Rpi 3. Does this issue have something to do with the lack of openGL on the iMX7?


  • Lifetime Qt Champion

    Hi,

    That might be the case. You should also add which version of Qt you are using. If possible also the configure options used to build the Qt version you are using.



  • Thanks for the reply. I expected to get a notice if someone replied to this thread, but I didn't.

    I've still been working through this. I've been able to reproduce the problem when compiling for desktop (running on Ubuntu 18.04.2 LTS) by adding this line to main() in the "gallery" sample application.

    QQuickWindow::setSceneGraphBackend(QSGRendererInterface::Software);

    It does seem to be something with the SW rendering. I don't really need or want to fancy animations of the Material.io theme--I just need the static "look" of the theme.

    Do you know if there is a way to globally turn off the "fancy effects" in QML?

    I'm using Qt version: 5.11.2. I'm not sure how to get the build configuration as I'm using Yocto and am still a novice. I'll look into this further.

    Thanks again for the reply.


  • Moderators

    @dbrown said in QML Rendering Issues on iMX7:

    Thanks for the reply. I expected to get a notice if someone replied to this thread, but I didn't.

    Are you set to be watching this thread? It should indicate at the bottom of the page if you are watching or not.


Log in to reply