Qt World Summit: Register Today!

Compiling my own 32-bit QT 5.12.4 libraries.

  • Hello, I am currently trying to transition from 5.10.1 32 bit to 5.12.4 on linux machines. However, I see that qt doesn't package a 32 bit libraries anymore and I should compile 5.12.4 source for 32-bit libraries. I am having trouble figuring out what steps I need to take to do this. Any help is much appreciated!

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You have the information in Qt's documentation.

  • Thank you very much for your help! I ran into another problem while configuring the library. So I did

    ./configure -platform linux-g++-32 

    and this error came up

    ERROR: The OpenGL functionality tests failed!
    You might need to modify the include and library search paths by editing QMAKE_INCDIR_OPENGL[_ES2],
    QMAKE_LIBDIR_OPENGL[_ES2] and QMAKE_LIBS_OPENGL[_ES2] in the mkspec for your platform.
    Check config.log for details.

    I tried to go into /qtbase/mkspecs/linux-g++-32 to see what I can do but I can't figure it out. I also tried

    sudo apt-get build-dep qt5-default

    and that didn't work. I am not really sure what to do next?

  • Lifetime Qt Champion

    @csing Did you install the 32bit version of libgl1-mesa-dev package?
    You also can add -v parameter to configure call, then you will get more verbose output which can help to identify the problem.

  • @jsulm thank you very much! I installed the libgl1-mesa-dev but not the libgl1-mesa-dev:i386 previously. It works now :)

Log in to reply