Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Nothing to be done for 'first'.



  • Hello everybody. I have some problem.
    When I run my application, I have this error message

    C:/Dev/Qt/Tools/mingw730_64/bin/mingw32-make -f Makefile.Debug
    mingw32-make[1]: Entering directory 'C:/Dev/Projects/Qt/tus'
    mingw32-make[1]: Nothing to be done for 'first'.
    mingw32-make[1]: Leaving directory 'C:/Dev/Projects/Qt/tus'
    

    So, I reinstalled Qt. Now I use Qt 5.12.4.
    I try to create new empty QML project and run it. Here has same problem.
    I assume that it problem with my Windows 10 Enterprise LTSB. Beacuse, after update, I got this problem.
    Has ideas how ti fix it?

    I tried to clean and run "Run QMAKE", build, it's not helped.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    It's not an error, it's just mingw32-make that says it has nothing to do. For example, if you compile an application twice in a row without modification to the code, that will happen because there's nothing new to do.



  • @SGaist okay, but my program is not running. How it fixed?



  • @auramel can you please go to compile tab and copy the error from there?? that will help us to know what is happening... also are you compile it or run it?? you have to press the run button!!!


  • Lifetime Qt Champion

    What exactly do you mean by not running ?
    Does not start ?
    Crashes ?
    What happens ?


  • Moderators

    hi @auramel and welcome,
    windows updates tend to ruin the path settings. For me, as I'm using MSCV, it's a real pain as basically each windows update the WindowsKits section (the windows developer kit install folder) get's messed up and I have to fix that manually.

    As @arsinte_andrei said, check your compile tab and see what issues your compiler actually has. It will help us helping you.


Log in to reply